summaryrefslogtreecommitdiffstats
path: root/dovecot
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-08-20 19:20:36 +0200
committerFlorian Pritz <bluewind@xssn.at>2009-08-20 19:20:36 +0200
commitf0d152ea0fe92423f39a487e97908d409f98047b (patch)
tree6396fb8e6a851f46f0cfc978c4720b3d2c3726b5 /dovecot
parent4955b0d9fc05950c5794c9cc37923deb00e9cfa5 (diff)
downloadaur-packages-f0d152ea0fe92423f39a487e97908d409f98047b.tar.gz
aur-packages-f0d152ea0fe92423f39a487e97908d409f98047b.tar.xz
some updates again
Diffstat (limited to 'dovecot')
-rw-r--r--dovecot/-1.2.1.tar.gz.part0
-rw-r--r--dovecot/PKGBUILD51
-rw-r--r--dovecot/dovecot-managesieve-1.2.1.tar.gz.part0
-rw-r--r--dovecot/dovecot-managesieve.install26
-rw-r--r--dovecot/dovecot.sh36
5 files changed, 113 insertions, 0 deletions
diff --git a/dovecot/-1.2.1.tar.gz.part b/dovecot/-1.2.1.tar.gz.part
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/dovecot/-1.2.1.tar.gz.part
diff --git a/dovecot/PKGBUILD b/dovecot/PKGBUILD
new file mode 100644
index 0000000..0421f9f
--- /dev/null
+++ b/dovecot/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id$
+#
+# Contributor: Paul Mattal <paul@mattal.com>
+# Contributor: Federico Quagliata (quaqo) <quaqo@despammed.com>
+# Contributor: GARETTE Emmanuel <gnunux at laposte dot net>
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=dovecot-managesieve
+_pkgname=dovecot
+pkgver=1.2.1
+_patchver=0.11.7
+pkgrel=1
+pkgdesc="An IMAP and POP3 server written with security primarily in mind"
+arch=('i686' 'x86_64')
+url="http://dovecot.org/"
+license=("LGPL")
+depends=("pam>=1.0.4" "libmysqlclient>=5.1.35-2" "postgresql-libs>=8.3.7" "sqlite3>=3.6.15-2" "db>=4.7.25.4"\
+ "heimdal>=1.2.1-5" 'libcap>=2.16-3' 'bzip2')
+optdepends=('libldap: ldap plugin')
+makedepends=('libldap>=2.3.43-3')
+provides=('imap-server' 'pop3-server')
+replaces=()
+options=('!libtool')
+install=$pkgname.install
+source=(http://dovecot.org/releases/1.2/${_pkgname}-${pkgver}.tar.gz dovecot.sh "http://www.rename-it.nl/dovecot/1.2/${_pkgname}-${pkgver}-managesieve-${_patchver}.diff.gz")
+md5sums=('c269cfe38fc40061e232dd28e5fe3721'
+ 'd020d43eab4ded6fb379dadc570a9490')
+
+build() {
+ cd ${srcdir}/${_pkgname}-$pkgver || return 1
+
+ patch -p1 < $srcdir/${_pkgname}-${pkgver}-managesieve-${_patchver}.diff || return 1
+
+ # configure with openssl, mysql, and postgresql support
+ ./configure --prefix=/usr --sysconfdir=/etc/dovecot --localstatedir=/var \
+ --libexecdir=/usr/lib --with-moduledir=/usr/lib/dovecot/modules \
+ --with-db --with-mysql --with-pgsql --with-sqlite \
+ --with-ssl=openssl --with-ssldir=/etc/dovecot/ssl \
+ --with-gssapi --with-ldap=plugin --enable-header-install --with-docs || return 1
+
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+
+ # install the launch script
+ install -D -m755 ${srcdir}/${_pkgname}.sh ${pkgdir}/etc/rc.d/${_pkgname} || return 1
+
+ # fix paths in the config example file where we have a different layout
+ sed -i 's|/usr/lib/dovecot|/usr/lib/dovecot/modules|g;
+ s|libexec|lib|g;
+ s|lib/sendmail|sbin/sendmail|g' $pkgdir/etc/dovecot/dovecot-example.conf || return 1
+}
diff --git a/dovecot/dovecot-managesieve-1.2.1.tar.gz.part b/dovecot/dovecot-managesieve-1.2.1.tar.gz.part
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/dovecot/dovecot-managesieve-1.2.1.tar.gz.part
diff --git a/dovecot/dovecot-managesieve.install b/dovecot/dovecot-managesieve.install
new file mode 100644
index 0000000..5175734
--- /dev/null
+++ b/dovecot/dovecot-managesieve.install
@@ -0,0 +1,26 @@
+# arg 1: the new package version
+post_install() {
+ if [ -z "`grep '^dovecot:' /etc/group`" ]; then
+ groupadd -g 76 dovecot >& /dev/null
+ fi
+ if [ -z "`grep '^dovecot:' /etc/passwd`" ]; then
+ useradd -u 76 -d /var/run/dovecot/login -g dovecot -s /bin/false dovecot
+ fi
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install $1
+}
+
+# arg 1: the old package version
+pre_remove() {
+ userdel dovecot &> /dev/null
+ groupdel dovecot &> /dev/null
+}
+
+op=$1
+shift
+
+$op $*
diff --git a/dovecot/dovecot.sh b/dovecot/dovecot.sh
new file mode 100644
index 0000000..b7555fe
--- /dev/null
+++ b/dovecot/dovecot.sh
@@ -0,0 +1,36 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/sbin/dovecot`
+case "$1" in
+ start)
+ stat_busy "Starting Dovecot"
+ [ -z "$PID" ] && /usr/sbin/dovecot
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ add_daemon dovecot
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping Dovecot"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon dovecot
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 2
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac
+exit 0