summaryrefslogtreecommitdiffstats
path: root/foo2zjs
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-09-12 20:39:28 +0200
committerFlorian Pritz <bluewind@xssn.at>2009-09-12 20:39:28 +0200
commitba8d9cff5bcbf35c3ab20609d3c21c0ec5d23c35 (patch)
treef8c1e4d894292f3deabf51bfb07b4e003007ddf7 /foo2zjs
parent5c68a85ffc09af00379d481c751c10c7e932b6fc (diff)
downloadaur-packages-ba8d9cff5bcbf35c3ab20609d3c21c0ec5d23c35.tar.gz
aur-packages-ba8d9cff5bcbf35c3ab20609d3c21c0ec5d23c35.tar.xz
update
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'foo2zjs')
-rw-r--r--foo2zjs/PKGBUILD31
-rw-r--r--foo2zjs/foo2zjs.install48
-rw-r--r--foo2zjs/makefile.patch45
3 files changed, 124 insertions, 0 deletions
diff --git a/foo2zjs/PKGBUILD b/foo2zjs/PKGBUILD
new file mode 100644
index 0000000..43c0f94
--- /dev/null
+++ b/foo2zjs/PKGBUILD
@@ -0,0 +1,31 @@
+#Contributor: Stefan Lohmaier <noneus@noneus.de>
+#Contributor: hubert_star
+pkgname=foo2zjs
+pkgver=20090424
+pkgrel=1
+pkgdesc="ZJStream Printer Drivers."
+url="http://foo2zjs.rkkda.com/"
+license="GPL"
+depends=(psutils cups foomatic-db-engine)
+makedepends=(wget unzip patch vim)
+arch=(i686 x86_64)
+install=foo2zjs.install
+source=(makefile.patch)
+md5sums=('46042339057e6390c98236a9da8b01ee')
+
+build() {
+ cd "$srcdir"
+ rm -f $pkgname.tar.gz
+ wget "http://foo2zjs.rkkda.com/$pkgname.tar.gz"
+ tar xfz $pkgname.tar.gz
+ cd $pkgname
+ patch -Np1 < ../makefile.patch || return 1
+ make || return 1
+ ./getweb all || return 1
+ mkdir -p $pkgdir/usr/bin $pkgdir/etc/udev/rules.d $pkgdir/bin
+ mkdir -p $pkgdir/usr/share/{foomatic/db/source/opt,/cups/model}
+ make DESTDIR=$pkgdir install || return 1
+ make DESTDIR=$pkgdir install-hotplug || return 1
+
+ chmod 755 $pkgdir/usr/share/{foo2oak/icm,foo2hp/icm,foo2zjs/crd,foo2zjs/firmware,foo2zjs/icm,foo2hiperc/icm,foo2lava/icm,foo2xqx/firmware,foo2qpdl/crd,foo2qpdl/icm,foo2slx/icm}
+}
diff --git a/foo2zjs/foo2zjs.install b/foo2zjs/foo2zjs.install
new file mode 100644
index 0000000..284f90b
--- /dev/null
+++ b/foo2zjs/foo2zjs.install
@@ -0,0 +1,48 @@
+# This is a default template for a post-install scriptlet. You can
+# remove any functions you don't need (and this header).
+
+# arg 1: the new package version
+pre_install() {
+ /bin/true
+}
+
+# arg 1: the new package version
+post_install() {
+ echo "-------------------------"
+ echo "You need to restart cups."
+ echo "-------------------------"
+ echo
+ echo "You need to add your user to the group \"lp\"."
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ echo "-------------------------"
+ echo "You need to restart cups."
+ echo "-------------------------"
+
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ echo "-------------------------"
+ echo "You need to restart cups."
+ echo "-------------------------"
+
+}
+
+op=$1
+shift
+$op $*
diff --git a/foo2zjs/makefile.patch b/foo2zjs/makefile.patch
new file mode 100644
index 0000000..b2d99e6
--- /dev/null
+++ b/foo2zjs/makefile.patch
@@ -0,0 +1,45 @@
+Binary files foo2zjsold/.Makefile.swp and foo2zjs/.Makefile.swp differ
+diff -ruN foo2zjsold/Makefile foo2zjs/Makefile
+--- foo2zjsold/Makefile 2009-02-23 20:18:37.793066344 +0100
++++ foo2zjs/Makefile 2009-02-23 20:21:59.653063789 +0100
+@@ -810,28 +810,18 @@
+ #
+
+ install-hotplug-prog:
+- if [ -d $(UDEVDIR) ]; then \
+- $(INSTALL) -c -m 644 $(RULES) $(UDEVDIR)/11-$(RULES); \
+- fi
+- [ -d $(USBDIR) ] || $(INSTALL) -d -m 755 $(USBDIR)/
+- $(INSTALL) -c -m 755 hplj1000 $(USBDIR)/
+- ln -sf $(USBDIR)/hplj1000 $(USBDIR)/hplj1005
+- ln -sf $(USBDIR)/hplj1000 $(USBDIR)/hplj1018
+- ln -sf $(USBDIR)/hplj1000 $(USBDIR)/hplj1020
+- ln -sf $(USBDIR)/hplj1000 $(USBDIR)/hpljP1005
+- ln -sf $(USBDIR)/hplj1000 $(USBDIR)/hpljP1006
+- ln -sf $(USBDIR)/hplj1000 $(USBDIR)/hpljP1007
+- ln -sf $(USBDIR)/hplj1000 $(USBDIR)/hpljP1008
+- ln -sf $(USBDIR)/hplj1000 $(USBDIR)/hpljP1505
+- $(USBDIR)/hplj1000 install-usermap
+- $(USBDIR)/hplj1005 install-usermap
+- $(USBDIR)/hplj1018 install-usermap
+- $(USBDIR)/hplj1020 install-usermap
+- $(USBDIR)/hpljP1005 install-usermap
+- $(USBDIR)/hpljP1006 install-usermap
+- $(USBDIR)/hpljP1007 install-usermap
+- $(USBDIR)/hpljP1008 install-usermap
+- $(USBDIR)/hpljP1505 install-usermap
++ [ -d $(DESTDIR)/$(UDEVDIR) ] || $(INSTALL) -d -m 755 $(DESTDIR)/$(UDEVDIR)/11-$(RULES)
++ $(INSTALL) -c -m 644 $(RULES) $(DESTDIR)/$(UDEVDIR)/11-$(RULES)
++ [ -d $(DESTDIR)/$(USBDIR) ] || $(INSTALL) -d -m 755 $(DESTDIR)/$(USBDIR)/
++ $(INSTALL) -c -m 755 hplj1000 $(DESTDIR)/$(USBDIR)/
++ ln -sf $(USBDIR)/hplj1000 $(DESTDIR)/$(USBDIR)/hplj1005
++ ln -sf $(USBDIR)/hplj1000 $(DESTDIR)/$(USBDIR)/hplj1018
++ ln -sf $(USBDIR)/hplj1000 $(DESTDIR)/$(USBDIR)/hplj1020
++ ln -sf $(USBDIR)/hplj1000 $(DESTDIR)/$(USBDIR)/hpljP1005
++ ln -sf $(USBDIR)/hplj1000 $(DESTDIR)/$(USBDIR)/hpljP1006
++ ln -sf $(USBDIR)/hplj1000 $(DESTDIR)/$(USBDIR)/hpljP1007
++ ln -sf $(USBDIR)/hplj1000 $(DESTDIR)/$(USBDIR)/hpljP1008
++ ln -sf $(USBDIR)/hplj1000 $(DESTDIR)/$(USBDIR)/hpljP1505
+
+ cups: FRC
+ if [ -x /etc/init.d/cups ]; then \