summaryrefslogtreecommitdiffstats
path: root/libowfat
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-08-20 19:20:36 +0200
committerFlorian Pritz <bluewind@xssn.at>2009-08-20 19:20:36 +0200
commitf0d152ea0fe92423f39a487e97908d409f98047b (patch)
tree6396fb8e6a851f46f0cfc978c4720b3d2c3726b5 /libowfat
parent4955b0d9fc05950c5794c9cc37923deb00e9cfa5 (diff)
downloadaur-packages-f0d152ea0fe92423f39a487e97908d409f98047b.tar.gz
aur-packages-f0d152ea0fe92423f39a487e97908d409f98047b.tar.xz
some updates again
Diffstat (limited to 'libowfat')
-rw-r--r--libowfat/PKGBUILD21
-rw-r--r--libowfat/libowfat.install39
2 files changed, 60 insertions, 0 deletions
diff --git a/libowfat/PKGBUILD b/libowfat/PKGBUILD
new file mode 100644
index 0000000..6b3dffe
--- /dev/null
+++ b/libowfat/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Alexander Ulrich <a.ulrich@student.uni-tuebingen.de>
+# Update: Mildred <silkensedai@online.fr>
+# Update: henning mueller <henning@orgizm.net>
+pkgname=libowfat
+pkgver=0.28
+pkgrel=1
+pkgdesc="GPL reimplementation of libdjb"
+arch=(i686 x86_64)
+url=http://www.fefe.de/libowfat/
+license=(GPL)
+install=libowfat.install
+source=(http://dl.fefe.de/$pkgname-$pkgver.tar.bz2)
+md5sums=(6bbee9a86506419657d87123b7a6f2c1)
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver/
+ make DIET= || return 1
+ make prefix=$startdir/pkg/usr/ LIBDIR=$startdir/pkg/usr/lib install
+ cd $startdir/pkg/usr/man/man3
+ mv buffer.3 buffer-libowfat.3
+}
diff --git a/libowfat/libowfat.install b/libowfat/libowfat.install
new file mode 100644
index 0000000..a08aef1
--- /dev/null
+++ b/libowfat/libowfat.install
@@ -0,0 +1,39 @@
+# This is a default template for a post-install scriptlet. You can
+# remove any functions you don't need (and this header).
+
+# arg 1: the new package version
+pre_install() {
+ /bin/true
+}
+
+# arg 1: the new package version
+post_install() {
+ echo "The manpage buffer(3) was moved to buffer-libowfat(3) because
+ it conflicts with package openssl"
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ /bin/true
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+$op $*