summaryrefslogtreecommitdiffstats
path: root/mod_wsgi
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-10-08 15:15:02 +0200
committerFlorian Pritz <bluewind@xssn.at>2009-10-08 15:15:02 +0200
commit0e671b67ef77114e39fdb239a921b70df58a4730 (patch)
tree0340be250523d029c0250b47c5021ce05d112b23 /mod_wsgi
parent2205ac0554474c618a642cd97f672c686d8021d0 (diff)
downloadaur-packages-0e671b67ef77114e39fdb239a921b70df58a4730.tar.gz
aur-packages-0e671b67ef77114e39fdb239a921b70df58a4730.tar.xz
upstream updates
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'mod_wsgi')
-rw-r--r--mod_wsgi/PKGBUILD19
-rw-r--r--mod_wsgi/mod_wsgi.install22
2 files changed, 41 insertions, 0 deletions
diff --git a/mod_wsgi/PKGBUILD b/mod_wsgi/PKGBUILD
new file mode 100644
index 0000000..e8c4265
--- /dev/null
+++ b/mod_wsgi/PKGBUILD
@@ -0,0 +1,19 @@
+# Contributor: Ryan Coyner <rcoyner@gmail.com>
+pkgname=mod_wsgi
+pkgver=2.6
+pkgrel=1
+pkgdesc="Python WSGI adapter module for Apache"
+arch=('i686' 'x86_64')
+url="http://www.modwsgi.org/"
+license=('Apache')
+depends=('apache>=1.3' 'python>=2.3')
+install=$pkgname.install
+source=(http://modwsgi.googlecode.com/files/$pkgname-$pkgver.tar.gz)
+md5sums=('c313cd7a662024866ce3376cb5a76cf6')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --with-apxs=/usr/sbin/apxs --with-python=/usr/bin/python || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
diff --git a/mod_wsgi/mod_wsgi.install b/mod_wsgi/mod_wsgi.install
new file mode 100644
index 0000000..ab4d12d
--- /dev/null
+++ b/mod_wsgi/mod_wsgi.install
@@ -0,0 +1,22 @@
+post_install() {
+/bin/cat << ENDOFMESSAGE
+==>
+==>
+==> To install mod_wsgi, add the following line in
+==> /etc/httpd/conf/httpd.conf file :
+==>
+==> LoadModule wsgi_module modules/mod_wsgi.so
+==>
+==> and restart/reload Apache.
+==>
+==>
+ENDOFMESSAGE
+}
+
+post_upgrade() {
+post_install
+}
+
+op=$1
+shift
+$op $*