summaryrefslogtreecommitdiffstats
path: root/mumble
diff options
context:
space:
mode:
authorFlorian Pritz <f-p@gmx.at>2009-03-26 19:41:58 +0100
committerFlorian Pritz <f-p@gmx.at>2009-03-26 19:41:58 +0100
commit87ec3d92c79bd4d933ea2ae2ad8794aa0e5fbf60 (patch)
tree31dd05e65663cd81223cd98cf3c7b2134378b42b /mumble
parent60309a9f54e880f9cf0f7d2a2d56c09b673d5558 (diff)
downloadaur-packages-87ec3d92c79bd4d933ea2ae2ad8794aa0e5fbf60.tar.gz
aur-packages-87ec3d92c79bd4d933ea2ae2ad8794aa0e5fbf60.tar.xz
update
Diffstat (limited to 'mumble')
-rw-r--r--mumble/PKGBUILD50
-rw-r--r--mumble/mumble.install42
2 files changed, 92 insertions, 0 deletions
diff --git a/mumble/PKGBUILD b/mumble/PKGBUILD
new file mode 100644
index 0000000..051974b
--- /dev/null
+++ b/mumble/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: Sebastian.Salich@gmx.de
+# Maintainer: Doc Angelo
+
+pkgname=mumble
+pkgver=1.1.8
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="A voice chat application similar to TeamSpeak"
+license=('GPL')
+depends=('alsa-lib' 'qt>=4.4.0' 'speex>=1.2rc1' 'lsb-release')
+makedepends=('pkgconfig' 'boost')
+conflicts=('mumble-client')
+options=('!libtool')
+install=mumble.install
+url="http://mumble.sourceforge.net/"
+source=("http://downloads.sourceforge.net/mumble/$pkgname-$pkgver.tar.gz" \
+ mumble.install)
+md5sums=('a7da012922d39b87c45d9f481d4b5efb'
+ 'dfa125deb91aa1abdaee7b6295fb488e')
+# If you want support for your G15 Keyboard, please add 'g15daemon'
+# to the depends and delete "no-g15" in the configure line below
+
+build() {
+ echo $srcdir
+ cd $srcdir/$pkgname-$pkgver
+
+ # Building mumble
+ /usr/bin/qmake main.pro \
+ CONFIG+="no-bundled-speex no-speechd no-g15 no-xevie no-server" \
+ DEFINES+="PLUGIN_PATH=/usr/lib/mumble/plugins" || exit 1
+ make || exit 1
+
+ # create directories and copy files
+ install -m755 -D ./release/mumble $pkgdir/usr/bin/mumble
+ install -m755 -D ./scripts/mumble-overlay $pkgdir/usr/bin/mumble-overlay
+ install -m755 -d $pkgdir/usr/lib/mumble/plugins
+ install -m755 -D ./release/libmumble.so.$pkgver $pkgdir/usr/lib/mumble/
+ ln -s libmumble.so.$pkgver $pkgdir/usr/lib/mumble/libmumble.so
+ ln -s libmumble.so.$pkgver $pkgdir/usr/lib/mumble/libmumble.so.1
+ ln -s libmumble.so.$pkgver $pkgdir/usr/lib/mumble/libmumble.so.1.1
+ install -m755 -D ./release/plugins/liblink.so $pkgdir/usr/lib/mumble/plugins/
+ install -m755 -d $pkgdir/usr/share/applications
+ install -m644 -D ./scripts/mumble.desktop $pkgdir/usr/share/applications/mumble.desktop
+ install -m755 -d $pkgdir/usr/share/man/man1
+ install -m644 -D ./man/mum* $pkgdir/usr/share/man/man1/
+ install -m644 -D ./icons/mumble.16x16.png $pkgdir/usr/share/icons/hicolor/16x16/apps/mumble.png
+ install -m644 -D ./icons/mumble.32x32.png $pkgdir/usr/share/icons/hicolor/32x32/apps/mumble.png
+ install -m644 -D ./icons/mumble.48x48.png $pkgdir/usr/share/icons/hicolor/48x48/apps/mumble.png
+ install -m644 -D ./icons/mumble.64x64.png $pkgdir/usr/share/icons/hicolor/64x64/apps/mumble.png
+}
diff --git a/mumble/mumble.install b/mumble/mumble.install
new file mode 100644
index 0000000..7c28ef5
--- /dev/null
+++ b/mumble/mumble.install
@@ -0,0 +1,42 @@
+# arg 1: the new package version
+pre_install() {
+ /bin/true
+}
+
+post_install() {
+ echo ' -> Mumble will generate an anonymous usage report'
+ echo ' -> 10 minutes after launch. You can deactivate this'
+ echo ' -> feature: Menu "Configure" > Settings > User'
+ echo ' -> Interface > "Expert Config" > Network > "Submit'
+ echo ' -> anonymous statistics"'
+ echo ''
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+}
+
+post_upgrade() {
+ echo ' -> Mumble will generate an anonymous usage report'
+ echo ' -> 10 minutes after launch. You can deactivate this'
+ echo ' -> feature: Menu "Configure" > Settings > User'
+ echo ' -> Interface > "Expert Config" > Network > "Submit'
+ echo ' -> anonymous statistics"'
+ echo ''
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+$op $*