summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Pritz <f-p@gmx.at>2009-03-26 19:41:58 +0100
committerFlorian Pritz <f-p@gmx.at>2009-03-26 19:41:58 +0100
commit87ec3d92c79bd4d933ea2ae2ad8794aa0e5fbf60 (patch)
tree31dd05e65663cd81223cd98cf3c7b2134378b42b
parent60309a9f54e880f9cf0f7d2a2d56c09b673d5558 (diff)
downloadaur-packages-87ec3d92c79bd4d933ea2ae2ad8794aa0e5fbf60.tar.gz
aur-packages-87ec3d92c79bd4d933ea2ae2ad8794aa0e5fbf60.tar.xz
update
-rw-r--r--deco-archive/PKGBUILD20
-rw-r--r--deco/PKGBUILD21
-rw-r--r--mumble/PKGBUILD50
-rw-r--r--mumble/mumble.install42
-rw-r--r--oss-hg/PKGBUILD70
-rw-r--r--oss-hg/oss.install59
-rw-r--r--oss-hg/oss.rc32
-rw-r--r--oss-hg/oss.rm-init-scripts.patch52
-rw-r--r--oss-mercurial/PKGBUILD59
-rw-r--r--oss-mercurial/oss.install59
-rw-r--r--oss-mercurial/oss.rc32
-rw-r--r--oss-mercurial/oss.rm-init-scripts.patch52
-rw-r--r--vlc-git/PKGBUILD70
-rw-r--r--vlc-git/vlc.install16
14 files changed, 634 insertions, 0 deletions
diff --git a/deco-archive/PKGBUILD b/deco-archive/PKGBUILD
new file mode 100644
index 0000000..9fd9bba
--- /dev/null
+++ b/deco-archive/PKGBUILD
@@ -0,0 +1,20 @@
+# Contributor: Christoph Zeiler <rabyte*gmail>
+
+pkgname=deco-archive
+pkgver=1.4
+pkgrel=1
+pkgdesc="A collection of extractor wrappers for the deco file extraction framework"
+arch=('any')
+url="http://hartlich.com/deco/archive/"
+license=('GPL3')
+depends=('bash' 'deco')
+source=($url/download/$pkgname-$pkgver.tar.gz)
+md5sums=('b48cd159fb73a65a4d6e491351c2e57e')
+
+build() {
+ cd $pkgname-$pkgver
+
+ make PREFIX=/usr DESTDIR=$pkgdir install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/deco/PKGBUILD b/deco/PKGBUILD
new file mode 100644
index 0000000..22f407e
--- /dev/null
+++ b/deco/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Christoph Zeiler <rabyte*gmail>
+
+pkgname=deco
+pkgver=1.6.0.1
+pkgrel=1
+pkgdesc="A command-line utility to extract various archive file formats"
+arch=('i686' 'x86_64')
+url="http://hartlich.com/deco/"
+license=('GPL3')
+optdepends=('deco-archive (extractor wrappers for various formats)')
+source=($url/download/$pkgname-$pkgver.tar.gz)
+md5sums=('7939b2bfae68cf753b8d8c5ff23d555c')
+
+build() {
+ cd $pkgname-$pkgver
+
+ make PREFIX=/usr CC=gcc CFLAGS="${CFLAGS}" || return 1
+ make PREFIX=/usr DESTDIR=$pkgdir install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/mumble/PKGBUILD b/mumble/PKGBUILD
new file mode 100644
index 0000000..051974b
--- /dev/null
+++ b/mumble/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: Sebastian.Salich@gmx.de
+# Maintainer: Doc Angelo
+
+pkgname=mumble
+pkgver=1.1.8
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="A voice chat application similar to TeamSpeak"
+license=('GPL')
+depends=('alsa-lib' 'qt>=4.4.0' 'speex>=1.2rc1' 'lsb-release')
+makedepends=('pkgconfig' 'boost')
+conflicts=('mumble-client')
+options=('!libtool')
+install=mumble.install
+url="http://mumble.sourceforge.net/"
+source=("http://downloads.sourceforge.net/mumble/$pkgname-$pkgver.tar.gz" \
+ mumble.install)
+md5sums=('a7da012922d39b87c45d9f481d4b5efb'
+ 'dfa125deb91aa1abdaee7b6295fb488e')
+# If you want support for your G15 Keyboard, please add 'g15daemon'
+# to the depends and delete "no-g15" in the configure line below
+
+build() {
+ echo $srcdir
+ cd $srcdir/$pkgname-$pkgver
+
+ # Building mumble
+ /usr/bin/qmake main.pro \
+ CONFIG+="no-bundled-speex no-speechd no-g15 no-xevie no-server" \
+ DEFINES+="PLUGIN_PATH=/usr/lib/mumble/plugins" || exit 1
+ make || exit 1
+
+ # create directories and copy files
+ install -m755 -D ./release/mumble $pkgdir/usr/bin/mumble
+ install -m755 -D ./scripts/mumble-overlay $pkgdir/usr/bin/mumble-overlay
+ install -m755 -d $pkgdir/usr/lib/mumble/plugins
+ install -m755 -D ./release/libmumble.so.$pkgver $pkgdir/usr/lib/mumble/
+ ln -s libmumble.so.$pkgver $pkgdir/usr/lib/mumble/libmumble.so
+ ln -s libmumble.so.$pkgver $pkgdir/usr/lib/mumble/libmumble.so.1
+ ln -s libmumble.so.$pkgver $pkgdir/usr/lib/mumble/libmumble.so.1.1
+ install -m755 -D ./release/plugins/liblink.so $pkgdir/usr/lib/mumble/plugins/
+ install -m755 -d $pkgdir/usr/share/applications
+ install -m644 -D ./scripts/mumble.desktop $pkgdir/usr/share/applications/mumble.desktop
+ install -m755 -d $pkgdir/usr/share/man/man1
+ install -m644 -D ./man/mum* $pkgdir/usr/share/man/man1/
+ install -m644 -D ./icons/mumble.16x16.png $pkgdir/usr/share/icons/hicolor/16x16/apps/mumble.png
+ install -m644 -D ./icons/mumble.32x32.png $pkgdir/usr/share/icons/hicolor/32x32/apps/mumble.png
+ install -m644 -D ./icons/mumble.48x48.png $pkgdir/usr/share/icons/hicolor/48x48/apps/mumble.png
+ install -m644 -D ./icons/mumble.64x64.png $pkgdir/usr/share/icons/hicolor/64x64/apps/mumble.png
+}
diff --git a/mumble/mumble.install b/mumble/mumble.install
new file mode 100644
index 0000000..7c28ef5
--- /dev/null
+++ b/mumble/mumble.install
@@ -0,0 +1,42 @@
+# arg 1: the new package version
+pre_install() {
+ /bin/true
+}
+
+post_install() {
+ echo ' -> Mumble will generate an anonymous usage report'
+ echo ' -> 10 minutes after launch. You can deactivate this'
+ echo ' -> feature: Menu "Configure" > Settings > User'
+ echo ' -> Interface > "Expert Config" > Network > "Submit'
+ echo ' -> anonymous statistics"'
+ echo ''
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+}
+
+post_upgrade() {
+ echo ' -> Mumble will generate an anonymous usage report'
+ echo ' -> 10 minutes after launch. You can deactivate this'
+ echo ' -> feature: Menu "Configure" > Settings > User'
+ echo ' -> Interface > "Expert Config" > Network > "Submit'
+ echo ' -> anonymous statistics"'
+ echo ''
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+$op $*
diff --git a/oss-hg/PKGBUILD b/oss-hg/PKGBUILD
new file mode 100644
index 0000000..0267f56
--- /dev/null
+++ b/oss-hg/PKGBUILD
@@ -0,0 +1,70 @@
+# Contributor: lh <jarryson#gmail.com>
+pkgname=oss-hg
+pkgver=666
+pkgrel=1
+pkgdesc="Open Sound System UNIX audio architecture"
+arch=('i686' 'x86_64')
+url="http://developer.opensound.com/"
+license=('GPL2')
+depends=('gcc' 'make' 'kernel-headers' 'module-init-tools' 'libtool' 'sed')
+makedepends=('pkgconfig' 'gawk' 'gtk2' 'mercurial')
+provides=('oss')
+conflicts=('oss-linux' 'oss-linux-free' 'oss-testing' 'oss' 'oss-mercurial')
+install='oss.install'
+source=('oss.rm-init-scripts.patch' 'oss.rc' 'oss.install')
+md5sums=('b9a380a0ac8896390d71ac13676f27e1'
+ '8ca7cdf94c56ab02890eb4aba6a4995f'
+ '1494a2304a1eb7a1979e7e83d894c67a')
+
+optdepends=('gtk2: for graphical mixer (ossxmix)'
+ 'hal: for automatic USB audio configuration'
+ 'libflashsupport-oss: for Flash plugin support')
+
+[ "$CARCH" = "x86_64" ] && optdepends[2]='lib32-libflashsupport-oss: for Flash plugin support'
+
+_hgroot=http://mercurial.opensound.com
+_hgrepo=oss
+
+build() {
+ cd $srcdir
+
+ if [ -d ${_hgrepo} ]; then
+ cd ${srcdir}/${_hgrepo}
+ hg pull -u
+ else
+ hg clone ${_hgroot} ${_hgrepo} || return 1
+ cd ${srcdir}/${_hgrepo}
+ fi
+
+ # Avoid these flags conflicting with OSS build system.
+ unset CFLAGS
+ unset OSFLAGS
+ unset LIBRARIES
+ export NO_WARNING_CHECKS=yes
+
+ # Remove libflashsupport, as it belongs to a separate package.
+ rm -f "$srcdir/$_hgrepo/oss/lib/flashsupport.c" &> /dev/null
+
+ msg "Preparing the build environment."
+
+ # have to remove this dir. because maybe the scource is different now.
+ rm -rf $srcdir/$_hgrepo-build
+ # Create build directory and configure
+ mkdir $srcdir/$_hgrepo-build && cd srcdir/$_hgrepo-build
+ "$srcdir/$_hgrepo/configure" --enable-libsalsa=NO || return 1
+
+ msg "Building OSS."
+ make build || return 1
+
+ msg "Patching init scripts."
+ cd "$srcdir/build/prototype"
+ rm usr/lib/oss/etc/S89oss
+ patch -b -p0 < "$srcdir/oss.rm-init-scripts.patch" || return 1
+
+ msg "Copying files."
+ cp -R * "$pkgdir"
+ chmod 755 "$pkgdir/usr/sbin/" "$pkgdir/usr/lib/oss/etc/" "$pkgdir/usr/lib/oss/build/"
+ install -D -m755 "$srcdir/oss.rc" "$pkgdir/etc/rc.d/oss"
+
+}
+
diff --git a/oss-hg/oss.install b/oss-hg/oss.install
new file mode 100644
index 0000000..f665416
--- /dev/null
+++ b/oss-hg/oss.install
@@ -0,0 +1,59 @@
+_MSG_LIBOSSDIR=" Please note that OSS stores some of its configuration files
+ at /usr/lib/oss. If you are upgrading from an older OSS
+ release and it doesn't work properly, try removing that
+ directory and reinstall this package."
+
+post_install() {
+ echo "Running OSS install script..."
+ /bin/sh /usr/lib/oss/build/install.sh &> /dev/null
+ echo
+ echo "-------------------------------------------------------------"
+ echo " Open Sound System was installed. Now you should add 'oss'"
+ echo " to your DAEMONS variable at /etc/rc.conf, and start the"
+ echo " daemon by running /etc/rc.d/oss start."
+ echo
+ echo " Note that OSS can't currently work together with kernel"
+ echo " ALSA modules, so they were moved out by the OSS install"
+ echo " scripts. If you want the ALSA kernel modules back, you can"
+ echo " just remove this package using pacman."
+ echo
+ echo "${_MSG_LIBOSSDIR}"
+ echo "-------------------------------------------------------------"
+ /bin/true
+}
+
+post_upgrade() {
+ echo "Running OSS update script..."
+ /bin/sh /usr/lib/oss/build/install.sh &> /dev/null
+ echo
+ echo "-------------------------------------------------------------"
+ echo " Open Sound System was updated. Now you should restart the"
+ echo " daemon by running /etc/rc.d/oss restart."
+ echo
+ echo "${_MSG_LIBOSSDIR}"
+ echo "-------------------------------------------------------------"
+ /bin/true
+}
+
+pre_remove() {
+ # Restore any replaced ALSA drivers.
+ /bin/sh /usr/lib/oss/scripts/restore_drv.sh
+ # Remove symlinks left by the 'install.sh' script.
+ rm -f /usr/lib/hal/scripts/oss_usb-create-devices
+ rm -f /usr/share/hal/fdi/policy/20thirdparty/90-oss_usb-create-device.fdi
+ /bin/true
+}
+
+post_remove() {
+ echo
+ echo "-------------------------------------------------------------"
+ echo " Open Sound System was now removed, and the ALSA kernel"
+ echo " modules were restored."
+ echo
+ echo " Please note that OSS stores some of its configuration files"
+ echo " at /usr/lib/oss. If you don't plan to use OSS anymore, you"
+ echo " can remove this directory."
+ echo "-------------------------------------------------------------"
+ /bin/true
+}
+
diff --git a/oss-hg/oss.rc b/oss-hg/oss.rc
new file mode 100644
index 0000000..3f63378
--- /dev/null
+++ b/oss-hg/oss.rc
@@ -0,0 +1,32 @@
+#!/bin/bash
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+case "$1" in
+ start)
+ stat_busy 'Starting Open Sound System'
+ if /usr/sbin/soundon
+ then
+ add_daemon oss
+ stat_done
+ else
+ stat_fail
+ fi
+ ;;
+ stop)
+ stat_busy 'Stopping Open Sound System'
+ if /usr/sbin/soundoff
+ then
+ rm_daemon oss
+ stat_done
+ else
+ stat_fail
+ fi
+ ;;
+ restart)
+ $0 stop
+ $0 start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart}"
+esac
diff --git a/oss-hg/oss.rm-init-scripts.patch b/oss-hg/oss.rm-init-scripts.patch
new file mode 100644
index 0000000..981ff60
--- /dev/null
+++ b/oss-hg/oss.rm-init-scripts.patch
@@ -0,0 +1,52 @@
+--- usr/lib/oss/build/install.sh.orig 2008-09-25 11:41:47.180167692 -0300
++++ usr/lib/oss/build/install.sh 2008-09-25 11:41:47.180167692 -0300
+@@ -290,38 +290,6 @@
+ echo
+ fi
+
+-if ! test -d /etc/init.d
+-then
+- mkdir /etc/init.d
+-fi
+-
+-rm -f /etc/init.d/oss /etc/rc.d/rc3.d/S89oss /etc/rc3.d/S89oss
+-cp -f $OSSLIBDIR/etc/S89oss /etc/init.d/oss
+-
+-chmod 744 /etc/init.d/oss
+-
+-if test -x /sbin/chkconfig
+-then
+- /sbin/chkconfig oss on > /dev/null 2>&1
+-else
+- if test -x /usr/sbin/update-rc.d
+- then
+- /usr/sbin/update-rc.d oss defaults > /dev/null 2>&1
+- else
+- if test -d etc/rc.d/rc3.d
+- then
+- rm -f /etc/rc.d/rc3.d/S89oss
+- ln -s /etc/init.d/oss /etc/rc.d/rc3.d/S89oss
+- else
+- if test -d /etc/rc3.d
+- then
+- rm -f /etc/rc3.d/S89oss
+- ln -s /etc/init.d/oss /etc/rc3.d/S89oss
+- fi
+- fi
+- fi
+-fi
+-
+ # Install ALSA interface module (Cuckoo)
+ #(cd $OSSLIBDIR/cuckoo && make clean) > /dev/null 2>&1
+ #if (cd $OSSLIBDIR/cuckoo && make install) > /var/log/cuckoo.log 2>&1
+--- usr/lib/oss/scripts/restore_drv.sh.orig 2008-09-25 11:41:47.210168487 -0300
++++ usr/lib/oss/scripts/restore_drv.sh 2008-09-25 11:41:47.210168487 -0300
+@@ -18,8 +18,6 @@
+ fi
+ fi
+
+-rm -f /etc/init.d/oss
+-
+ if ! test -d /lib/modules/`uname -r`/kernel/sound
+ then
+ if test -f /lib/modules/`uname -r`/sound-preoss.tar.bz2
diff --git a/oss-mercurial/PKGBUILD b/oss-mercurial/PKGBUILD
new file mode 100644
index 0000000..daea34a
--- /dev/null
+++ b/oss-mercurial/PKGBUILD
@@ -0,0 +1,59 @@
+# This is a modified version of the oss pkg in community
+pkgname="oss-mercurial"
+pkgver="4.1"
+pkgrel=3
+pkgdesc="Open Sound System UNIX audio architecture"
+arch=('i686' 'x86_64')
+url="http://developer.opensound.com/"
+license=('GPL2')
+depends=('gcc' 'make' 'kernel-headers' 'module-init-tools' 'libtool' 'sed')
+makedepends=('pkgconfig' 'gawk' 'gtk2' 'mercurial')
+provides=('oss')
+conflicts=('oss-linux' 'oss-linux-free' 'oss-testing' 'oss')
+install='oss.install'
+source=('oss.rm-init-scripts.patch' 'oss.rc' 'oss.install')
+md5sums=('b9a380a0ac8896390d71ac13676f27e1'
+ '8ca7cdf94c56ab02890eb4aba6a4995f'
+ '1494a2304a1eb7a1979e7e83d894c67a')
+
+optdepends=('gtk2: for graphical mixer (ossxmix)'
+ 'hal: for automatic USB audio configuration')
+
+build() {
+ #_dir="oss-v4.1-buildrc2-src-gpl"
+ _dir="mercurial.opensound.com"
+
+ cd "$srcdir"
+ hg clone http://mercurial.opensound.com
+
+ # Avoid these flags conflicting with OSS build system.
+ unset CFLAGS
+ unset OSFLAGS
+ unset LIBRARIES
+
+ msg "Preparing the build environment."
+
+ if [ ! -d build ]; then
+ # Create build directory and configure
+ mkdir build && cd build
+ "$srcdir/$_dir/configure" --enable-libsalsa=NO || return 1
+ else
+ # Change to existing build directory
+ cd build
+ fi
+
+ msg "Building OSS."
+ make build || return 1
+
+ msg "Patching init scripts."
+ cd "$srcdir/build/prototype"
+ rm usr/lib/oss/etc/S89oss
+ patch -b -p0 < "$srcdir/oss.rm-init-scripts.patch" || return 1
+
+ msg "Copying files."
+ cp -R * "$pkgdir"
+ chmod 755 "$pkgdir/usr/sbin/" "$pkgdir/usr/lib/oss/etc/" "$pkgdir/usr/lib/oss/build/"
+ install -D -m755 "$srcdir/oss.rc" "$pkgdir/etc/rc.d/oss"
+
+}
+
diff --git a/oss-mercurial/oss.install b/oss-mercurial/oss.install
new file mode 100644
index 0000000..f665416
--- /dev/null
+++ b/oss-mercurial/oss.install
@@ -0,0 +1,59 @@
+_MSG_LIBOSSDIR=" Please note that OSS stores some of its configuration files
+ at /usr/lib/oss. If you are upgrading from an older OSS
+ release and it doesn't work properly, try removing that
+ directory and reinstall this package."
+
+post_install() {
+ echo "Running OSS install script..."
+ /bin/sh /usr/lib/oss/build/install.sh &> /dev/null
+ echo
+ echo "-------------------------------------------------------------"
+ echo " Open Sound System was installed. Now you should add 'oss'"
+ echo " to your DAEMONS variable at /etc/rc.conf, and start the"
+ echo " daemon by running /etc/rc.d/oss start."
+ echo
+ echo " Note that OSS can't currently work together with kernel"
+ echo " ALSA modules, so they were moved out by the OSS install"
+ echo " scripts. If you want the ALSA kernel modules back, you can"
+ echo " just remove this package using pacman."
+ echo
+ echo "${_MSG_LIBOSSDIR}"
+ echo "-------------------------------------------------------------"
+ /bin/true
+}
+
+post_upgrade() {
+ echo "Running OSS update script..."
+ /bin/sh /usr/lib/oss/build/install.sh &> /dev/null
+ echo
+ echo "-------------------------------------------------------------"
+ echo " Open Sound System was updated. Now you should restart the"
+ echo " daemon by running /etc/rc.d/oss restart."
+ echo
+ echo "${_MSG_LIBOSSDIR}"
+ echo "-------------------------------------------------------------"
+ /bin/true
+}
+
+pre_remove() {
+ # Restore any replaced ALSA drivers.
+ /bin/sh /usr/lib/oss/scripts/restore_drv.sh
+ # Remove symlinks left by the 'install.sh' script.
+ rm -f /usr/lib/hal/scripts/oss_usb-create-devices
+ rm -f /usr/share/hal/fdi/policy/20thirdparty/90-oss_usb-create-device.fdi
+ /bin/true
+}
+
+post_remove() {
+ echo
+ echo "-------------------------------------------------------------"
+ echo " Open Sound System was now removed, and the ALSA kernel"
+ echo " modules were restored."
+ echo
+ echo " Please note that OSS stores some of its configuration files"
+ echo " at /usr/lib/oss. If you don't plan to use OSS anymore, you"
+ echo " can remove this directory."
+ echo "-------------------------------------------------------------"
+ /bin/true
+}
+
diff --git a/oss-mercurial/oss.rc b/oss-mercurial/oss.rc
new file mode 100644
index 0000000..3f63378
--- /dev/null
+++ b/oss-mercurial/oss.rc
@@ -0,0 +1,32 @@
+#!/bin/bash
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+case "$1" in
+ start)
+ stat_busy 'Starting Open Sound System'
+ if /usr/sbin/soundon
+ then
+ add_daemon oss
+ stat_done
+ else
+ stat_fail
+ fi
+ ;;
+ stop)
+ stat_busy 'Stopping Open Sound System'
+ if /usr/sbin/soundoff
+ then
+ rm_daemon oss
+ stat_done
+ else
+ stat_fail
+ fi
+ ;;
+ restart)
+ $0 stop
+ $0 start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart}"
+esac
diff --git a/oss-mercurial/oss.rm-init-scripts.patch b/oss-mercurial/oss.rm-init-scripts.patch
new file mode 100644
index 0000000..981ff60
--- /dev/null
+++ b/oss-mercurial/oss.rm-init-scripts.patch
@@ -0,0 +1,52 @@
+--- usr/lib/oss/build/install.sh.orig 2008-09-25 11:41:47.180167692 -0300
++++ usr/lib/oss/build/install.sh 2008-09-25 11:41:47.180167692 -0300
+@@ -290,38 +290,6 @@
+ echo
+ fi
+
+-if ! test -d /etc/init.d
+-then
+- mkdir /etc/init.d
+-fi
+-
+-rm -f /etc/init.d/oss /etc/rc.d/rc3.d/S89oss /etc/rc3.d/S89oss
+-cp -f $OSSLIBDIR/etc/S89oss /etc/init.d/oss
+-
+-chmod 744 /etc/init.d/oss
+-
+-if test -x /sbin/chkconfig
+-then
+- /sbin/chkconfig oss on > /dev/null 2>&1
+-else
+- if test -x /usr/sbin/update-rc.d
+- then
+- /usr/sbin/update-rc.d oss defaults > /dev/null 2>&1
+- else
+- if test -d etc/rc.d/rc3.d
+- then
+- rm -f /etc/rc.d/rc3.d/S89oss
+- ln -s /etc/init.d/oss /etc/rc.d/rc3.d/S89oss
+- else
+- if test -d /etc/rc3.d
+- then
+- rm -f /etc/rc3.d/S89oss
+- ln -s /etc/init.d/oss /etc/rc3.d/S89oss
+- fi
+- fi
+- fi
+-fi
+-
+ # Install ALSA interface module (Cuckoo)
+ #(cd $OSSLIBDIR/cuckoo && make clean) > /dev/null 2>&1
+ #if (cd $OSSLIBDIR/cuckoo && make install) > /var/log/cuckoo.log 2>&1
+--- usr/lib/oss/scripts/restore_drv.sh.orig 2008-09-25 11:41:47.210168487 -0300
++++ usr/lib/oss/scripts/restore_drv.sh 2008-09-25 11:41:47.210168487 -0300
+@@ -18,8 +18,6 @@
+ fi
+ fi
+
+-rm -f /etc/init.d/oss
+-
+ if ! test -d /lib/modules/`uname -r`/kernel/sound
+ then
+ if test -f /lib/modules/`uname -r`/sound-preoss.tar.bz2
diff --git a/vlc-git/PKGBUILD b/vlc-git/PKGBUILD
new file mode 100644
index 0000000..ed2174f
--- /dev/null
+++ b/vlc-git/PKGBUILD
@@ -0,0 +1,70 @@
+#Contributor: MacWolf <macwolf@archlinux.de>
+
+pkgname=vlc-git
+pkgver=20090326
+pkgrel=1
+pkgdesc="VideoLAN Client is a multi-platform MPEG, VCD/DVD, and DivX player.Development GIT Version."
+depends=('libmad' 'libmpeg2' 'ffmpeg' \
+ 'hal' 'fluidsynth' 'zvbi' 'lua'\
+ 'libdvbpsi' 'fribidi' 'sysfsutils' \
+ 'libdvdnav' 'libnotify' 'libdvdread' \
+ 'libmatroska' 'libcddb' 'libmpcdec'\
+ 'faad2' 'qt' 'libmodplug' 'speex' 'sdl_image' \
+ 'libxml2' 'libdca' 'libxv' 'avahi' 'taglib')
+arch=(i686 x86_64)
+makedepends=('a52dec' 'make' 'm4' 'pkgconfig' 'automake' 'autoconf' 'git' 'live-media>=2008.09.02')
+install=vlc.install
+url="http://www.videolan.org/vlc/"
+license=(GPL)
+conflicts=('vlc' 'vlc-svn' 'vlc-nightly')
+provides=('vlc' 'vlc-svn' 'vlc-nightly')
+source=()
+md5sums=()
+
+_gitroot=git://git.videolan.org/vlc.git
+_gitname=vlc
+
+build() {
+cd $startdir/src
+
+if [ -d $_gitname ]; then
+ cd $_gitname && git pull origin
+ cd ..
+else
+ git clone $_gitroot
+fi
+
+rm -rf $_gitname-build
+#cp -r $_gitname $_gitname-build
+git clone $_gitname $_gitname-build
+
+msg "GIT checkout done or server timeout"
+
+cd $_gitname-build
+
+msg "Generating necessary files"
+
+./bootstrap
+
+msg "Generating done."
+
+msg "Starting make..."
+
+ [ "${CARCH}" = "i686" ] && EXTRAFEATURES="--enable-loader --disable-live555 --with-live555-tree=/usr/lib/live-media"
+ [ "${CARCH}" = "x86_64" ] && EXTRAFEATURES="--enable-fast-install"
+
+./configure --prefix=/usr --enable-dvdread --enable-dvdnav --enable-madi --enable-ffmpeg --disable-rpath --enable-faad --enable-v4l --enable-dvb --enable-dmo --enable-qt4 --enable-theora --enable-flac --enable-skins2 ${EXTRAFEATURES} || return 1
+
+ make || return 1
+ make DESTDIR=$startdir/pkg install || return 1
+
+ for res in 16 32 48; do
+ install -D -m644 share/vlc${res}x${res}.png \
+ $startdir/pkg/usr/share/icons/hicolor/${res}x${res}/apps/vlc.png || return 1
+ done
+
+ install -D -m644 $startdir/src/vlc/share/applications/vlc.desktop \
+ $startdir/pkg/usr/share/applications/vlc.desktop || return 1
+
+ rm -rf ${startdir}/pkg/usr/lib/mozilla
+}
diff --git a/vlc-git/vlc.install b/vlc-git/vlc.install
new file mode 100644
index 0000000..382dbde
--- /dev/null
+++ b/vlc-git/vlc.install
@@ -0,0 +1,16 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+$op $*