summaryrefslogtreecommitdiffstats
path: root/munin-node/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-08-20 19:20:36 +0200
committerFlorian Pritz <bluewind@xssn.at>2009-08-20 19:20:36 +0200
commitf0d152ea0fe92423f39a487e97908d409f98047b (patch)
tree6396fb8e6a851f46f0cfc978c4720b3d2c3726b5 /munin-node/PKGBUILD
parent4955b0d9fc05950c5794c9cc37923deb00e9cfa5 (diff)
downloadaur-packages-f0d152ea0fe92423f39a487e97908d409f98047b.tar.gz
aur-packages-f0d152ea0fe92423f39a487e97908d409f98047b.tar.xz
some updates again
Diffstat (limited to 'munin-node/PKGBUILD')
-rw-r--r--munin-node/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/munin-node/PKGBUILD b/munin-node/PKGBUILD
new file mode 100644
index 0000000..de756a4
--- /dev/null
+++ b/munin-node/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Roberto Alsina <ralsina@kde.org>
+pkgname=munin-node
+pkgver=1.2.6
+pkgrel=12
+pkgdesc="A distributed monitoring/graphing agent"
+arch=('i686' 'x86_64')
+url="http://munin.sf.net"
+license=("GPL")
+depends=(perl perl-net-server which)
+backup=(etc/munin/munin-node.conf)
+install=munin-node.install
+source=(http://downloads.sourceforge.net/sourceforge/munin/munin_$pkgver.tar.gz \
+ Makefile.config munin-node.init munin-node.runit munin-node.finish munin-node.install)
+
+md5sums=('45f84d58f80642ce914f147232f0d396' '686cef93dee285949a0451c81b691085'\
+ '14872c731f99d5f9d831115b2f5e282e' '422000b064a03023b8dee2c76eee0548'\
+ '39eb25fec876123cff9c6927d4a9d46a' 'aa8e338183ae2f4602bcaedfc6ca8927')
+
+build() {
+cd $srcdir/munin-$pkgver
+cp $srcdir/Makefile.config $srcdir/munin-$pkgver || exit 1
+
+make PREFIX='' || exit 1
+make DESTDIR=$pkgdir install-node install-node-plugins || exit 1
+
+sed -i "s|\$ENV{'MUNIN_HOSTNAME'}.*|\$ENV{'MUNIN_HOSTNAME'} = \`hostname\`;|g" $pkgdir/sbin/munin-node
+sed -i "s|\$ENV{'MUNIN_HOSTNAME'}.*|\$ENV{'MUNIN_HOSTNAME'} = \`hostname\`;|g" $pkgdir/sbin/munin-run
+
+install -D -m0755 -o root ../munin-node.init $pkgdir/etc/rc.d/munin-node
+install -D -m0755 -o root ../munin-node.runit $pkgdir/etc/munin-node/run
+install -D -m0755 -o root ../munin-node.finish $pkgdir/etc/munin-node/finish
+}