summaryrefslogtreecommitdiffstats
path: root/nikto
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2010-03-01 20:40:50 +0100
committerFlorian Pritz <bluewind@xssn.at>2010-03-01 20:40:50 +0100
commitf23d273a395cbdfd8a1197adc3509ba3dfb4637b (patch)
tree976676e90713a1a7d3691998d8999df04b720040 /nikto
parent351991ce3e10dfae9cf57e7cf79fcca9b01c585b (diff)
downloadaur-packages-f23d273a395cbdfd8a1197adc3509ba3dfb4637b.tar.gz
aur-packages-f23d273a395cbdfd8a1197adc3509ba3dfb4637b.tar.xz
update
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'nikto')
-rw-r--r--nikto/PKGBUILD25
-rw-r--r--nikto/nikto.install13
-rw-r--r--nikto/nikto.sh4
3 files changed, 42 insertions, 0 deletions
diff --git a/nikto/PKGBUILD b/nikto/PKGBUILD
new file mode 100644
index 0000000..6b4c282
--- /dev/null
+++ b/nikto/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Arkham <arkham at archlinux dot us>
+# Contributor: Arkham <arkham at archlinux dot us>
+
+pkgname=nikto
+pkgver=2.1.1
+pkgrel=1
+pkgdesc='A web server scanner which performs comprehensive tests against web servers for multiple items'
+url='http://www.cirt.net/code/nikto.shtml'
+license=('GPL')
+arch=('any')
+depends=('perl' 'openssl' 'perl-net-ssleay')
+install=$pkgname.install
+source=(http://www.cirt.net/nikto/$pkgname-$pkgver.tar.gz
+ nikto.sh)
+md5sums=('a9404c3f464b08f3f48788d5f39e0ca7'
+ 'eb7b704c8bdae28af9a0353764d0b552')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ install -d $pkgdir/usr/share/nikto
+ cp -a * $pkgdir/usr/share/nikto/
+ find $pkgdir/usr/share/nikto -type f -exec chmod 644 {} +
+ install -Dm 755 $srcdir/nikto.sh $pkgdir/usr/bin/nikto
+}
diff --git a/nikto/nikto.install b/nikto/nikto.install
new file mode 100644
index 0000000..aefdd93
--- /dev/null
+++ b/nikto/nikto.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo "> Don't forget to update your plugins running as root:"
+ echo "> nikto -update"
+ echo ""
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ /bin/true
+}
diff --git a/nikto/nikto.sh b/nikto/nikto.sh
new file mode 100644
index 0000000..8d36d2a
--- /dev/null
+++ b/nikto/nikto.sh
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+cd /usr/share/nikto
+perl nikto.pl $@