summaryrefslogtreecommitdiffstats
path: root/oss-hg
diff options
context:
space:
mode:
authorFlorian Pritz <f-p@gmx.at>2009-03-26 19:41:58 +0100
committerFlorian Pritz <f-p@gmx.at>2009-03-26 19:41:58 +0100
commit87ec3d92c79bd4d933ea2ae2ad8794aa0e5fbf60 (patch)
tree31dd05e65663cd81223cd98cf3c7b2134378b42b /oss-hg
parent60309a9f54e880f9cf0f7d2a2d56c09b673d5558 (diff)
downloadaur-packages-87ec3d92c79bd4d933ea2ae2ad8794aa0e5fbf60.tar.gz
aur-packages-87ec3d92c79bd4d933ea2ae2ad8794aa0e5fbf60.tar.xz
update
Diffstat (limited to 'oss-hg')
-rw-r--r--oss-hg/PKGBUILD70
-rw-r--r--oss-hg/oss.install59
-rw-r--r--oss-hg/oss.rc32
-rw-r--r--oss-hg/oss.rm-init-scripts.patch52
4 files changed, 213 insertions, 0 deletions
diff --git a/oss-hg/PKGBUILD b/oss-hg/PKGBUILD
new file mode 100644
index 0000000..0267f56
--- /dev/null
+++ b/oss-hg/PKGBUILD
@@ -0,0 +1,70 @@
+# Contributor: lh <jarryson#gmail.com>
+pkgname=oss-hg
+pkgver=666
+pkgrel=1
+pkgdesc="Open Sound System UNIX audio architecture"
+arch=('i686' 'x86_64')
+url="http://developer.opensound.com/"
+license=('GPL2')
+depends=('gcc' 'make' 'kernel-headers' 'module-init-tools' 'libtool' 'sed')
+makedepends=('pkgconfig' 'gawk' 'gtk2' 'mercurial')
+provides=('oss')
+conflicts=('oss-linux' 'oss-linux-free' 'oss-testing' 'oss' 'oss-mercurial')
+install='oss.install'
+source=('oss.rm-init-scripts.patch' 'oss.rc' 'oss.install')
+md5sums=('b9a380a0ac8896390d71ac13676f27e1'
+ '8ca7cdf94c56ab02890eb4aba6a4995f'
+ '1494a2304a1eb7a1979e7e83d894c67a')
+
+optdepends=('gtk2: for graphical mixer (ossxmix)'
+ 'hal: for automatic USB audio configuration'
+ 'libflashsupport-oss: for Flash plugin support')
+
+[ "$CARCH" = "x86_64" ] && optdepends[2]='lib32-libflashsupport-oss: for Flash plugin support'
+
+_hgroot=http://mercurial.opensound.com
+_hgrepo=oss
+
+build() {
+ cd $srcdir
+
+ if [ -d ${_hgrepo} ]; then
+ cd ${srcdir}/${_hgrepo}
+ hg pull -u
+ else
+ hg clone ${_hgroot} ${_hgrepo} || return 1
+ cd ${srcdir}/${_hgrepo}
+ fi
+
+ # Avoid these flags conflicting with OSS build system.
+ unset CFLAGS
+ unset OSFLAGS
+ unset LIBRARIES
+ export NO_WARNING_CHECKS=yes
+
+ # Remove libflashsupport, as it belongs to a separate package.
+ rm -f "$srcdir/$_hgrepo/oss/lib/flashsupport.c" &> /dev/null
+
+ msg "Preparing the build environment."
+
+ # have to remove this dir. because maybe the scource is different now.
+ rm -rf $srcdir/$_hgrepo-build
+ # Create build directory and configure
+ mkdir $srcdir/$_hgrepo-build && cd srcdir/$_hgrepo-build
+ "$srcdir/$_hgrepo/configure" --enable-libsalsa=NO || return 1
+
+ msg "Building OSS."
+ make build || return 1
+
+ msg "Patching init scripts."
+ cd "$srcdir/build/prototype"
+ rm usr/lib/oss/etc/S89oss
+ patch -b -p0 < "$srcdir/oss.rm-init-scripts.patch" || return 1
+
+ msg "Copying files."
+ cp -R * "$pkgdir"
+ chmod 755 "$pkgdir/usr/sbin/" "$pkgdir/usr/lib/oss/etc/" "$pkgdir/usr/lib/oss/build/"
+ install -D -m755 "$srcdir/oss.rc" "$pkgdir/etc/rc.d/oss"
+
+}
+
diff --git a/oss-hg/oss.install b/oss-hg/oss.install
new file mode 100644
index 0000000..f665416
--- /dev/null
+++ b/oss-hg/oss.install
@@ -0,0 +1,59 @@
+_MSG_LIBOSSDIR=" Please note that OSS stores some of its configuration files
+ at /usr/lib/oss. If you are upgrading from an older OSS
+ release and it doesn't work properly, try removing that
+ directory and reinstall this package."
+
+post_install() {
+ echo "Running OSS install script..."
+ /bin/sh /usr/lib/oss/build/install.sh &> /dev/null
+ echo
+ echo "-------------------------------------------------------------"
+ echo " Open Sound System was installed. Now you should add 'oss'"
+ echo " to your DAEMONS variable at /etc/rc.conf, and start the"
+ echo " daemon by running /etc/rc.d/oss start."
+ echo
+ echo " Note that OSS can't currently work together with kernel"
+ echo " ALSA modules, so they were moved out by the OSS install"
+ echo " scripts. If you want the ALSA kernel modules back, you can"
+ echo " just remove this package using pacman."
+ echo
+ echo "${_MSG_LIBOSSDIR}"
+ echo "-------------------------------------------------------------"
+ /bin/true
+}
+
+post_upgrade() {
+ echo "Running OSS update script..."
+ /bin/sh /usr/lib/oss/build/install.sh &> /dev/null
+ echo
+ echo "-------------------------------------------------------------"
+ echo " Open Sound System was updated. Now you should restart the"
+ echo " daemon by running /etc/rc.d/oss restart."
+ echo
+ echo "${_MSG_LIBOSSDIR}"
+ echo "-------------------------------------------------------------"
+ /bin/true
+}
+
+pre_remove() {
+ # Restore any replaced ALSA drivers.
+ /bin/sh /usr/lib/oss/scripts/restore_drv.sh
+ # Remove symlinks left by the 'install.sh' script.
+ rm -f /usr/lib/hal/scripts/oss_usb-create-devices
+ rm -f /usr/share/hal/fdi/policy/20thirdparty/90-oss_usb-create-device.fdi
+ /bin/true
+}
+
+post_remove() {
+ echo
+ echo "-------------------------------------------------------------"
+ echo " Open Sound System was now removed, and the ALSA kernel"
+ echo " modules were restored."
+ echo
+ echo " Please note that OSS stores some of its configuration files"
+ echo " at /usr/lib/oss. If you don't plan to use OSS anymore, you"
+ echo " can remove this directory."
+ echo "-------------------------------------------------------------"
+ /bin/true
+}
+
diff --git a/oss-hg/oss.rc b/oss-hg/oss.rc
new file mode 100644
index 0000000..3f63378
--- /dev/null
+++ b/oss-hg/oss.rc
@@ -0,0 +1,32 @@
+#!/bin/bash
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+case "$1" in
+ start)
+ stat_busy 'Starting Open Sound System'
+ if /usr/sbin/soundon
+ then
+ add_daemon oss
+ stat_done
+ else
+ stat_fail
+ fi
+ ;;
+ stop)
+ stat_busy 'Stopping Open Sound System'
+ if /usr/sbin/soundoff
+ then
+ rm_daemon oss
+ stat_done
+ else
+ stat_fail
+ fi
+ ;;
+ restart)
+ $0 stop
+ $0 start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart}"
+esac
diff --git a/oss-hg/oss.rm-init-scripts.patch b/oss-hg/oss.rm-init-scripts.patch
new file mode 100644
index 0000000..981ff60
--- /dev/null
+++ b/oss-hg/oss.rm-init-scripts.patch
@@ -0,0 +1,52 @@
+--- usr/lib/oss/build/install.sh.orig 2008-09-25 11:41:47.180167692 -0300
++++ usr/lib/oss/build/install.sh 2008-09-25 11:41:47.180167692 -0300
+@@ -290,38 +290,6 @@
+ echo
+ fi
+
+-if ! test -d /etc/init.d
+-then
+- mkdir /etc/init.d
+-fi
+-
+-rm -f /etc/init.d/oss /etc/rc.d/rc3.d/S89oss /etc/rc3.d/S89oss
+-cp -f $OSSLIBDIR/etc/S89oss /etc/init.d/oss
+-
+-chmod 744 /etc/init.d/oss
+-
+-if test -x /sbin/chkconfig
+-then
+- /sbin/chkconfig oss on > /dev/null 2>&1
+-else
+- if test -x /usr/sbin/update-rc.d
+- then
+- /usr/sbin/update-rc.d oss defaults > /dev/null 2>&1
+- else
+- if test -d etc/rc.d/rc3.d
+- then
+- rm -f /etc/rc.d/rc3.d/S89oss
+- ln -s /etc/init.d/oss /etc/rc.d/rc3.d/S89oss
+- else
+- if test -d /etc/rc3.d
+- then
+- rm -f /etc/rc3.d/S89oss
+- ln -s /etc/init.d/oss /etc/rc3.d/S89oss
+- fi
+- fi
+- fi
+-fi
+-
+ # Install ALSA interface module (Cuckoo)
+ #(cd $OSSLIBDIR/cuckoo && make clean) > /dev/null 2>&1
+ #if (cd $OSSLIBDIR/cuckoo && make install) > /var/log/cuckoo.log 2>&1
+--- usr/lib/oss/scripts/restore_drv.sh.orig 2008-09-25 11:41:47.210168487 -0300
++++ usr/lib/oss/scripts/restore_drv.sh 2008-09-25 11:41:47.210168487 -0300
+@@ -18,8 +18,6 @@
+ fi
+ fi
+
+-rm -f /etc/init.d/oss
+-
+ if ! test -d /lib/modules/`uname -r`/kernel/sound
+ then
+ if test -f /lib/modules/`uname -r`/sound-preoss.tar.bz2