summaryrefslogtreecommitdiffstats
path: root/pacman-git
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xinu.at>2011-10-23 22:01:53 +0200
committerFlorian Pritz <bluewind@xinu.at>2011-10-23 22:02:18 +0200
commitebc82b27288df5c58194083ead4a6e6de7f52d21 (patch)
tree30d4e874cc19a03dfc62a0ee7c6c5e6c9756d4ec /pacman-git
parent44c6e7dfa4967843b05ee961fd243f655ed31717 (diff)
downloadaur-packages-ebc82b27288df5c58194083ead4a6e6de7f52d21.tar.gz
aur-packages-ebc82b27288df5c58194083ead4a6e6de7f52d21.tar.xz
mass update (again :( )
Signed-off-by: Florian Pritz <bluewind@xinu.at>
Diffstat (limited to 'pacman-git')
-rw-r--r--pacman-git/PKGBUILD23
-rw-r--r--pacman-git/makepkg.conf6
-rw-r--r--pacman-git/pacman.conf7
-rw-r--r--pacman-git/pacman.conf.x86_647
4 files changed, 31 insertions, 12 deletions
diff --git a/pacman-git/PKGBUILD b/pacman-git/PKGBUILD
index 2a95d09..51d9187 100644
--- a/pacman-git/PKGBUILD
+++ b/pacman-git/PKGBUILD
@@ -4,27 +4,26 @@
# Contributor: Andres Perera <aepd87@gmail.com>
pkgname=pacman-git
-pkgver=20110112
+pkgver=20110428
pkgrel=1
pkgdesc="A library-based package manager with dependency support. git version."
arch=('i686' 'x86_64')
url="http://www.archlinux.org/pacman/"
license=('GPL')
groups=('base')
-depends=('bash' 'libarchive>=2.7.1' 'libfetch>=2.25' 'pacman-mirrorlist')
+depends=('bash' 'curl>=7.19.4' 'gpgme' 'libarchive>=2.7.1' 'pacman-mirrorlist')
makedepends=('git' 'asciidoc')
-optdepends=('fakeroot: for makepkg usage as normal user'
- 'curl: for rankmirrors usage')
+optdepends=('fakeroot: for makepkg usage as normal user')
backup=(etc/pacman.conf etc/makepkg.conf)
conflicts=('pacman')
provides=('pacman')
-options=(!libtool)
+options=(!libtool !strip)
source=(pacman.conf
pacman.conf.x86_64
makepkg.conf)
-md5sums=('eda9cbdb47f85fabda2e7e63801e3e16'
- '9ba146b4fa7bcb3cc18204b06d1f6157'
- 'aef317285c7d16ac495b0e53deeb948d')
+md5sums=('10c2b220d4d2ec37a54ab7d8982acdd2'
+ 'c6559dc43140e9023041171e72bd91e8'
+ 'a7be38e9fcf92414ded8c7f9574a5a9b')
_gitroot="git://projects.archlinux.org/pacman.git"
_gitname="pacman"
@@ -48,10 +47,16 @@ build() {
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --enable-doc \
- --enable-git-version
+ --enable-git-version --enable-debug
make
}
+check() {
+ cd "$srcdir/$_gitname-build"
+
+ make check
+}
+
package() {
cd "$srcdir/$_gitname-build"
diff --git a/pacman-git/makepkg.conf b/pacman-git/makepkg.conf
index ff08a0f..c23d039 100644
--- a/pacman-git/makepkg.conf
+++ b/pacman-git/makepkg.conf
@@ -8,9 +8,9 @@
#
#-- The download utilities that makepkg should use to acquire sources
# Format: 'protocol::agent'
-DLAGENTS=('ftp::/usr/bin/wget -c --passive-ftp -t 3 --waitretry=3 -O %o %u'
- 'http::/usr/bin/wget -c -t 3 --waitretry=3 -O %o %u'
- 'https::/usr/bin/wget -c -t 3 --waitretry=3 --no-check-certificate -O %o %u'
+DLAGENTS=('ftp::/usr/bin/curl -fC - --ftp-pasv --retry 3 --retry-delay 3 -o %o %u'
+ 'http::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -o %o %u'
+ 'https::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -o %o %u'
'rsync::/usr/bin/rsync -z %u %o'
'scp::/usr/bin/scp -C %u %o')
diff --git a/pacman-git/pacman.conf b/pacman-git/pacman.conf
index 3a5d875..f5fcce1 100644
--- a/pacman-git/pacman.conf
+++ b/pacman-git/pacman.conf
@@ -48,6 +48,7 @@ Architecture = auto
# [repo-name]
# Server = ServerName
# Include = IncludePath
+# VerifySig = Always/Optional/Never
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
@@ -59,21 +60,27 @@ Architecture = auto
#[testing]
#Include = /etc/pacman.d/mirrorlist
+#VerifySig = Optional
[core]
Include = /etc/pacman.d/mirrorlist
+VerifySig = Optional
[extra]
Include = /etc/pacman.d/mirrorlist
+VerifySig = Optional
#[community-testing]
#Include = /etc/pacman.d/mirrorlist
+#VerifySig = Optional
[community]
Include = /etc/pacman.d/mirrorlist
+VerifySig = Optional
# An example of a custom package repository. See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#Server = file:///home/custompkgs
+#VerifySig = Optional
diff --git a/pacman-git/pacman.conf.x86_64 b/pacman-git/pacman.conf.x86_64
index e825b4b..52b84d4 100644
--- a/pacman-git/pacman.conf.x86_64
+++ b/pacman-git/pacman.conf.x86_64
@@ -48,6 +48,7 @@ Architecture = auto
# [repo-name]
# Server = ServerName
# Include = IncludePath
+# VerifySig = Always/Optional/Never
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
@@ -59,23 +60,29 @@ Architecture = auto
#[testing]
#Include = /etc/pacman.d/mirrorlist
+#VerifySig = Optional
[core]
Include = /etc/pacman.d/mirrorlist
+VerifySig = Optional
[extra]
Include = /etc/pacman.d/mirrorlist
+VerifySig = Optional
#[community-testing]
#Include = /etc/pacman.d/mirrorlist
+#VerifySig = Optional
[community]
Include = /etc/pacman.d/mirrorlist
+VerifySig = Optional
# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repository here.
#[multilib]
#Include = /etc/pacman.d/mirrorlist
+#VerifySig = Optional
# An example of a custom package repository. See the pacman manpage for
# tips on creating your own repositories.