summaryrefslogtreecommitdiffstats
path: root/perl-file-next
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-08-20 19:20:36 +0200
committerFlorian Pritz <bluewind@xssn.at>2009-08-20 19:20:36 +0200
commitf0d152ea0fe92423f39a487e97908d409f98047b (patch)
tree6396fb8e6a851f46f0cfc978c4720b3d2c3726b5 /perl-file-next
parent4955b0d9fc05950c5794c9cc37923deb00e9cfa5 (diff)
downloadaur-packages-f0d152ea0fe92423f39a487e97908d409f98047b.tar.gz
aur-packages-f0d152ea0fe92423f39a487e97908d409f98047b.tar.xz
some updates again
Diffstat (limited to 'perl-file-next')
-rw-r--r--perl-file-next/ChangeLog23
-rw-r--r--perl-file-next/PKGBUILD27
2 files changed, 50 insertions, 0 deletions
diff --git a/perl-file-next/ChangeLog b/perl-file-next/ChangeLog
new file mode 100644
index 0000000..8d57268
--- /dev/null
+++ b/perl-file-next/ChangeLog
@@ -0,0 +1,23 @@
+2009-08-05 Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+ * 1.06-1 :
+ Updated to the latest version.
+ Changed to arch=('any')
+
+
+2009-07-31 Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+ * 1.04-1 :
+ Updated to the latest version.
+
+
+2009-05-21 Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+ * 1.02-2 :
+ Replaced in my '# Contributor:' line by '# Maintainer:'
+
+
+2009-03-02 Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+ * 1.02-1 :
+ Initial release
diff --git a/perl-file-next/PKGBUILD b/perl-file-next/PKGBUILD
new file mode 100644
index 0000000..53fe9a6
--- /dev/null
+++ b/perl-file-next/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+pkgname=perl-file-next
+_pkgname=File-Next
+pkgver=1.06
+pkgrel=1
+pkgdesc='File::Next - File-finding iterator'
+arch=('any')
+license=('GPL' 'PerlArtistic')
+url="http://search.cpan.org/dist/${_pkgname}"
+depends=('perl>=5.10.0')
+options=(!emptydirs)
+
+source=(http://search.cpan.org/CPAN/authors/id/P/PE/PETDANCE/${_pkgname}-$pkgver.tar.gz)
+md5sums=('8d901b18e40c477acd18a6ea0fd7de64')
+
+build() {
+ cd $srcdir/${_pkgname}-$pkgver
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+
+ make || return 1
+ make install DESTDIR=$pkgdir || return 1
+
+ find $pkgdir -name perllocal.pod -delete
+ find $pkgdir -name .packlist -delete
+}