summaryrefslogtreecommitdiffstats
path: root/php/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-11-26 18:02:59 +0100
committerFlorian Pritz <bluewind@xssn.at>2009-11-26 18:03:07 +0100
commit1db94feb0c1ea3d1b4cb69c044a9379c8f0f847d (patch)
tree35938e2ceb6b55e4cf544abfe59420be2753af5c /php/PKGBUILD
parent796f87cf34f485d18ef3b055615a1381df17d841 (diff)
downloadaur-packages-1db94feb0c1ea3d1b4cb69c044a9379c8f0f847d.tar.gz
aur-packages-1db94feb0c1ea3d1b4cb69c044a9379c8f0f847d.tar.xz
updates
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'php/PKGBUILD')
-rw-r--r--php/PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/php/PKGBUILD b/php/PKGBUILD
index 79806a9..33fe6e7 100644
--- a/php/PKGBUILD
+++ b/php/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id$
+# $Id: PKGBUILD 59035 2009-11-19 16:11:32Z pierre $
# Maintainer: Pierre Schmitz <pierre@archlinux.de>
pkgbase=php
@@ -20,9 +20,9 @@ pkgname=('php'
'php-sqlite'
'php-tidy'
'php-xsl')
-pkgver=5.3.0
-pkgrel=3
-_suhosinver=${pkgver}-0.9.8-BETA-1
+pkgver=5.3.1
+pkgrel=1
+_suhosinver=${pkgver}RC1-0.9.8
arch=('i686' 'x86_64')
license=('PHP')
url='http://www.php.net'
@@ -33,13 +33,13 @@ makedepends=('apache' 'imap' 'postgresql-libs' 'mysql' 'libldap' 'postfix'
options=('!makeflags')
source=("http://www.php.net/distributions/${pkgbase}-${pkgver}.tar.bz2"
"http://download.suhosin.org/suhosin-patch-${_suhosinver}.patch.gz"
- 'php.ini.patch' 'apache.conf' 'db-configure.patch' 'gd-info-segfault.patch')
-md5sums=('846760cd655c98dfd86d6d97c3d964b0'
- '62dc36545b86bf86e44ada1fccc17d0a'
- '67c63d2c8a976a333bbd2216cdd60413'
+ 'php.ini.patch' 'apache.conf' 'db-configure.patch' 'mysqlnd-socket.patch')
+md5sums=('63e97ad450f0f7259e785100b634c797'
+ 'c3ff0cb5fa728420d56f8ed139446647'
+ 'd6f94150f47047882c6716575e12e99b'
'96ca078be6729b665be8a865535a97bf'
- '45ecb6fb0aadfd3462097e3bab951aa5'
- '1c1a50aae7207b12d27bdecd8967e7ce')
+ 'cd3d068931c3715e35634e9885e35374'
+ '993223e03e6c0cc2d89581550ebbbe67')
build() {
phpconfig="--prefix=/usr \
@@ -95,7 +95,7 @@ build() {
--with-jpeg-dir=shared,/usr \
--with-ldap=shared \
--with-mcrypt=shared \
- --with-mysql-sock=/tmp/mysql.sock \
+ --with-mysql-sock=/var/run/mysqld/mysqld.sock \
--with-mysql=shared,mysqlnd \
--with-mysqli=shared,mysqlnd \
--with-openssl=shared \
@@ -130,15 +130,15 @@ build() {
# avoid linking against old db version
patch -p0 -i ${srcdir}/db-configure.patch || return 1
+ # use /var/run/mysqld/mysqld.sock as default socket for mysql
+ patch -p0 -i ${srcdir}/mysqlnd-socket.patch || return 1
+
# apply suhosin patch
patch -p1 -i ${srcdir}/suhosin-patch-${_suhosinver}.patch || return 1
# adjust paths
patch -p0 -i ${srcdir}/php.ini.patch || return 1
- # fix gd segfault; http://bugs.php.net/bug.php?id=49193
- patch -p0 -i ${srcdir}/gd-info-segfault.patch || return 1
-
# php
mkdir ${srcdir}/build-php
cd ${srcdir}/build-php