summaryrefslogtreecommitdiffstats
path: root/portbunny
diff options
context:
space:
mode:
authorFlorian Pritz <f-p@gmx.at>2009-02-28 14:36:14 +0100
committerFlorian Pritz <f-p@gmx.at>2009-02-28 14:36:14 +0100
commit3232f9d90114778cb8d38cc1bc8477435dc65259 (patch)
tree0eb9ffafbe853c84b9ad6b808d86a00d44668392 /portbunny
downloadaur-packages-3232f9d90114778cb8d38cc1bc8477435dc65259.tar.gz
aur-packages-3232f9d90114778cb8d38cc1bc8477435dc65259.tar.xz
initial commit
Diffstat (limited to 'portbunny')
-rw-r--r--portbunny/PKGBUILD26
-rw-r--r--portbunny/installpath.patch59
-rw-r--r--portbunny/portbunny.install20
3 files changed, 105 insertions, 0 deletions
diff --git a/portbunny/PKGBUILD b/portbunny/PKGBUILD
new file mode 100644
index 0000000..bc315c6
--- /dev/null
+++ b/portbunny/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Martijn F. Arts <mfa@devtty0.de>
+pkgname=portbunny
+pkgver="050109_dev"
+pkgrel=1
+pkgdesc="A fast TCP-SYN Linux-kernel-based port-scanner"
+arch=('i686' 'x86_64')
+url="http://www.recurity-labs.com/portbunny/"
+license=('GPL')
+depends=('python>=2.4')
+makedepends=('make' 'gcc' 'kernel-headers')
+install=$pkgname.install
+source=("http://portbunny.recurity.com/tarballs/PortBunny050109-dev.tar.gz" "installpath.patch")
+build() {
+ cd "$startdir/src/PortBunny050109-dev"
+ patch -p1 < ../installpath.patch
+ make || return 1050109_dev
+ mkdir -p $startdir/pkg/lib/modules/$(uname -r)/kernel/ $startdir/pkg/usr/share/portbunny || return 1
+ mkdir -p $startdir/pkg/usr/bin || return 1
+ DESTDIR="$startdir/pkg" make install || return 1
+}
+
+# vim:set ts=2 sw=2 et:
+md5sums=('792ceed6d20e5035f9dc1fcc318d2bbe'
+ 'd056310ab5b14b6f859907b6fac7ae5d')
+sha512sums=('195ddb595aef73d4458b56f03ae558da605789f07d64c757be210980dcb9ae35da83411fd72cd7fb863b87de2a1db8a835d549347b2835c6455bb910022830c0'
+ '88f6bd4aa8fcaf954f18a00ae84ed47d66967ed0f58f7aaa5fde6150e06b5cd60739bbee0df42d15b29b1047f5786886122951be9eabe908f17297e7a86c0586')
diff --git a/portbunny/installpath.patch b/portbunny/installpath.patch
new file mode 100644
index 0000000..96b12ef
--- /dev/null
+++ b/portbunny/installpath.patch
@@ -0,0 +1,59 @@
+diff -Nur PortBunny050109-dev/Makefile PortBunny050109-dev-arch/Makefile
+--- PortBunny050109-dev/Makefile 2009-01-05 14:21:47.000000000 +0100
++++ PortBunny050109-dev-arch/Makefile 2009-01-14 22:38:49.300678488 +0100
+@@ -49,5 +49,5 @@
+
+ install:
+
+- $(shell install -m 644 portbunny.ko /lib/modules/$(shell uname -r)/kernel/portbunny.ko; /sbin/depmod -a)
+- $(shell cp -r ./UI/* /usr/local/)
++ install -m 644 portbunny.ko ${DESTDIR}/lib/modules/$(shell uname -r)/kernel/portbunny.ko
++ cp -r ./UI/* ${DESTDIR}/usr/
+diff -Nur PortBunny050109-dev/UI/bin/portbunny PortBunny050109-dev-arch/UI/bin/portbunny
+--- PortBunny050109-dev/UI/bin/portbunny 2008-10-26 08:41:32.000000000 +0100
++++ PortBunny050109-dev-arch/UI/bin/portbunny 2009-01-14 22:38:13.567338951 +0100
+@@ -12,7 +12,7 @@
+
+
+ PBUNNY_SHARE = '../share/portbunny/'
+-PBUNNY_SHARE2 = '/usr/local/share/portbunny/'
++PBUNNY_SHARE2 = '/usr/share/portbunny/'
+
+ import sys
+ import time
+diff -Nur PortBunny050109-dev/UI/bin/portbunny.py PortBunny050109-dev-arch/UI/bin/portbunny.py
+--- PortBunny050109-dev/UI/bin/portbunny.py 2008-10-26 08:41:32.000000000 +0100
++++ PortBunny050109-dev-arch/UI/bin/portbunny.py 2009-01-14 22:38:13.567338951 +0100
+@@ -12,7 +12,7 @@
+
+
+ PBUNNY_SHARE = '../share/portbunny/'
+-PBUNNY_SHARE2 = '/usr/local/share/portbunny/'
++PBUNNY_SHARE2 = '/usr/share/portbunny/'
+
+ import sys
+ import time
+diff -Nur PortBunny050109-dev/UI/share/portbunny/PBunnyServices.py PortBunny050109-dev-arch/UI/share/portbunny/PBunnyServices.py
+--- PortBunny050109-dev/UI/share/portbunny/PBunnyServices.py 2008-10-26 08:41:32.000000000 +0100
++++ PortBunny050109-dev-arch/UI/share/portbunny/PBunnyServices.py 2009-01-14 22:38:25.061728150 +0100
+@@ -7,7 +7,7 @@
+
+ ETC_SERVICES = '../share/portbunny/services'
+ if not os.path.exists(ETC_SERVICES):
+- ETC_SERVICES = '/usr/local/share/portbunny/services'
++ ETC_SERVICES = '/usr/share/portbunny/services'
+
+
+ """
+diff -Nur PortBunny050109-dev/scanner_ui/scanner_ui.c PortBunny050109-dev-arch/scanner_ui/scanner_ui.c
+--- PortBunny050109-dev/scanner_ui/scanner_ui.c 2008-10-26 08:41:30.000000000 +0100
++++ PortBunny050109-dev-arch/scanner_ui/scanner_ui.c 2009-01-14 22:37:59.164038548 +0100
+@@ -344,7 +344,7 @@
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,12)
+
+ #if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,25)
+- device_create_drvdata(portbunny_class, NULL, MKDEV(major, 0), NULL, "portbunny");
++ device_create(portbunny_class, NULL, MKDEV(major, 0), NULL, "portbunny");
+ #else
+ class_device_create(portbunny_class, NULL, MKDEV(major, 0), NULL, "portbunny");
+ #endif
diff --git a/portbunny/portbunny.install b/portbunny/portbunny.install
new file mode 100644
index 0000000..f923755
--- /dev/null
+++ b/portbunny/portbunny.install
@@ -0,0 +1,20 @@
+# arg 1: the new package version
+post_install() {
+ /sbin/depmod -a
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ /sbin/depmod -a
+}
+
+post_remove() {
+ /sbin/depmod -a
+}
+
+op=$1
+shift
+[ "$(type -t "$op")" = "function" ] && $op "$@"
+
+# vim:set ts=2 sw=2 et: