summaryrefslogtreecommitdiffstats
path: root/thunderbird3
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-11-22 21:42:30 +0100
committerFlorian Pritz <bluewind@xssn.at>2009-11-22 21:42:30 +0100
commit7155de6730bac6549b53cb08b746581d5ce4fa50 (patch)
treeba3f486c77c0608a2a108047cde2eeb612901d90 /thunderbird3
parentac2be60a6f3e6805f9c4a5986fc9bdc67798f4c5 (diff)
downloadaur-packages-7155de6730bac6549b53cb08b746581d5ce4fa50.tar.gz
aur-packages-7155de6730bac6549b53cb08b746581d5ce4fa50.tar.xz
updates
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'thunderbird3')
-rw-r--r--thunderbird3/PKGBUILD57
-rw-r--r--thunderbird3/default_locale.patch11
-rw-r--r--thunderbird3/mozconfig36
-rw-r--r--thunderbird3/thunderbird3.desktop10
4 files changed, 114 insertions, 0 deletions
diff --git a/thunderbird3/PKGBUILD b/thunderbird3/PKGBUILD
new file mode 100644
index 0000000..4e1a659
--- /dev/null
+++ b/thunderbird3/PKGBUILD
@@ -0,0 +1,57 @@
+# Contibutor: Andreas Schönfelder <passtschu at freenet dot de>
+
+pkgname=thunderbird3
+pkgver=3.0b4
+pkgrel=5
+pkgdesc="Standalone Mail/News reader (installs besides thunderbird2)"
+arch=('i686' 'x86_64')
+license=('MPL' 'GPL')
+url="http://www.mozilla.org/projects/thunderbird"
+depends=('gtk2>=2.14.7' 'gcc-libs>=4.3.3' 'libidl2' 'mozilla-common' 'libxt' 'shared-mime-info')
+makedepends=('zip' 'pkgconfig' 'imagemagick' 'libgnomeui' 'dbus' 'python')
+options=('!ccache' '!distcc')
+source=(ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${pkgver}/source/thunderbird-${pkgver}.source.tar.bz2
+ mozconfig
+ thunderbird3.desktop
+ default_locale.patch)
+md5sums=('0f7c7cdfebd8948b7e3fe835773b072d'
+ '8a3b273574d76f6cb3a255afce84e00c'
+ 'da268f4dbf6fbb8efa13221f39d9fb32'
+ '39fe15f99264dc1b6776059de87dfa88')
+
+build() {
+ cd "${srcdir}"
+ cp "${srcdir}/mozconfig" comm-central/.mozconfig
+ cd comm-central/
+
+ patch -Np1 -i "${srcdir}/default_locale.patch" || return 1
+
+ unset CFLAGS
+ unset CXXFLAGS
+ unset LDFLAGS
+
+ if [ "${CARCH}" = "x86_64" ]; then
+ echo "ac_cv_visibility_pragma=no" >> .mozconfig
+ fi
+
+ export MOZ_PROJECT=mail
+
+ make -f client.mk build || return 1
+ make -j1 DESTDIR="${pkgdir}" -C objdir-tb install|| return 1
+
+ rm -rf "${pkgdir}/usr/bin/defaults"
+
+ mv "${pkgdir}/usr/bin/thunderbird"{,3}
+ install -m755 -d "${pkgdir}/usr/share/applications"
+ install -m755 -d "${pkgdir}/usr/share/pixmaps"
+ install -m644 "${srcdir}/comm-central/other-licenses/branding/thunderbird/mailicon48.png" "${pkgdir}/usr/share/pixmaps/thunderbird3.png"
+
+ #Is this a bug??? What happened to default.xpm?!
+ convert "${srcdir}/comm-central/other-licenses/branding/thunderbird/mailicon48.png" "${srcdir}/comm-central/other-licenses/branding/thunderbird/default.xpm"
+
+ install -m644 "${srcdir}/comm-central/other-licenses/branding/thunderbird/default.xpm" \
+ "${pkgdir}/usr/lib/thunderbird-${pkgver}/icons/" || return 1
+ install -m644 "${srcdir}/thunderbird3.desktop" "${pkgdir}/usr/share/applications/"
+
+ rm -f ${pkgdir}/usr/lib/pkgconfig/thunderbird-ns{s,pr}.pc
+}
diff --git a/thunderbird3/default_locale.patch b/thunderbird3/default_locale.patch
new file mode 100644
index 0000000..6b903cd
--- /dev/null
+++ b/thunderbird3/default_locale.patch
@@ -0,0 +1,11 @@
+--- comm-central/mozilla/modules/libpref/src/init/all.js 2009-10-11 02:12:44.000000000 +0200
++++ comm-central/mozilla/modules/libpref/src/init/all.js 2009-09-16 02:56:45.000000000 +0200
+@@ -890,7 +890,7 @@
+ pref("intl.charset.detector", "chrome://global/locale/intl.properties");
+ pref("intl.charset.default", "chrome://global-platform/locale/intl.properties");
+ pref("intl.ellipsis", "chrome://global-platform/locale/intl.properties");
+-pref("intl.locale.matchOS", false);
++pref("intl.locale.matchOS", true);
+ // fallback charset list for Unicode conversion (converting from Unicode)
+ // currently used for mail send only to handle symbol characters (e.g Euro, trademark, smartquotes)
+ // for ISO-8859-1
diff --git a/thunderbird3/mozconfig b/thunderbird3/mozconfig
new file mode 100644
index 0000000..db7abae
--- /dev/null
+++ b/thunderbird3/mozconfig
@@ -0,0 +1,36 @@
+mk_add_options MOZ_CO_PROJECT=mail
+ac_add_options --enable-application=mail
+mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/objdir-tb/
+mk_add_options AUTOCONF=autoconf-2.13
+
+ac_add_options --prefix=/usr --libdir=/usr/lib
+
+#ac_add_options --with-system-nspr
+#ac_add_options --with-system-nss
+#ac_add_options --with-system-jpeg
+ac_add_options --with-system-zlib
+ac_add_options --with-pthreads
+ac_add_options --disable-tests
+ac_add_options --disable-debug
+ac_add_options --disable-installer
+ac_add_options --enable-optimize
+ac_add_options --enable-xinerama
+ac_add_options --enable-default-toolkit=cairo-gtk2
+ac_add_options --enable-official-branding
+ac_add_options --disable-xprint
+ac_add_options --disable-strip
+ac_add_options --disable-install-strip
+ac_add_options --enable-pango
+ac_add_options --enable-system-cairo
+ac_add_options --enable-svg
+ac_add_options --enable-canvas
+ac_add_options --disable-crashreporter
+ac_add_options --enable-static
+ac_add_options --enable-calendar
+
+mk_add_options MOZ_MAKE_FLAGS=-j3
+
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+mk_add_options BUILD_OFFICIAL=1
+mk_add_options MOZILLA_OFFICIAL=1
diff --git a/thunderbird3/thunderbird3.desktop b/thunderbird3/thunderbird3.desktop
new file mode 100644
index 0000000..619f6f9
--- /dev/null
+++ b/thunderbird3/thunderbird3.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Thunderbird3
+Comment=Mail & News Reader
+Exec=thunderbird3
+Icon=thunderbird3.png
+Terminal=false
+Type=Application
+Categories=Application;Network;
+StartupNotify=true