summaryrefslogtreecommitdiffstats
path: root/weechat-git
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-11-01 11:55:07 +0100
committerFlorian Pritz <bluewind@xssn.at>2009-11-01 11:55:07 +0100
commit833dcdb1ed487375152a5a66dda0be87f07a066e (patch)
tree4a0ef1154a6ba9eb2392b77bac3dfe85ac51d586 /weechat-git
parentf49a0527334a7fc7f41d7b6b97783aac30c9a302 (diff)
downloadaur-packages-833dcdb1ed487375152a5a66dda0be87f07a066e.tar.gz
aur-packages-833dcdb1ed487375152a5a66dda0be87f07a066e.tar.xz
upstream updates
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'weechat-git')
-rw-r--r--weechat-git/PKGBUILD73
-rw-r--r--weechat-git/weechatgit.install13
2 files changed, 38 insertions, 48 deletions
diff --git a/weechat-git/PKGBUILD b/weechat-git/PKGBUILD
index fd6eaec..6c18c93 100644
--- a/weechat-git/PKGBUILD
+++ b/weechat-git/PKGBUILD
@@ -2,53 +2,48 @@
# Contributor: Tim Zebulla <amon at faumrahrer dot de>
pkgname=weechat-git
-pkgver=20090613
+pkgver=20091022
pkgrel=1
-install=('weechatgit.install')
pkgdesc="Fast, light & extensible IRC client (curses UI)"
arch=('i686' 'x86_64')
url="http://weechat.flashtux.org"
-depends=('perl' 'python>=2.5' 'gnutls' 'lua' 'aspell' 'iksemel' 'ruby<1.9')
+license=('GPL3')
+depends=('aspell' 'iksemel')
makedepends=('git' 'cmake')
-optdepends=('tcl: tcl scripting support')
+optdepends=('tcl: tcl scripting support'
+ 'perl>=5.10: perl scripting support'
+ 'python>=2.6: python scripting support'
+ 'lua: lua scripting support')
+provides=('weechat')
+conflicts=('weechat')
options=(!strip)
-license=('GPL3')
-source=()
-md5sums=()
+install=weechatgit.install
_gitroot="git://git.sv.gnu.org/weechat.git"
-_gitrepo="weechat"
-
-build(){
- cd $startdir/src
-
- msg ""
- msg "Connecting to GIT server..."
-
- if [ ! -d $startdir/src/$_gitrepo ]; then
- msg "First time connected - cloning repo, this may take a while..."
- git clone $_gitroot || return 1
- else
- cd $startdir/src/$_gitrepo
- msg "Updating files..."
- git pull || return 1
- fi
-
- msg "Starting build process..."
-
- cp -r $startdir/src/$_gitrepo $startdir/src/$_gitrepo-build && cd $startdir/src/$_gitrepo-build
-
-# Installs to /usr/local so people can run both stable and devel versions
-# at the same time. Otherwise, change it to /usr
-
- cmake -DCMAKE_BUILD_TYPE=Debug -DDISABLE_DOC=ON -DPREFIX=/usr || return 1
-
- make DESTDIR=${startdir}/pkg install || return 1
-
- rm -r $startdir/src/$_gitrepo-build
-
-}
-
+_gitname="weechat"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ msg "First time connected - cloning repo, this may take a while..."
+ git clone $_gitroot
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting cmake..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ cmake -DCMAKE_BUILD_TYPE=Debug -DDISABLE_RUBY=ON -DDISABLE_DOC=ON -DPREFIX=/usr || return 1
+ make DESTDIR="$pkgdir/" install
+}
# note - to disable an option, use -DDISABLE_JABBER=ON
# this should change soon, and will be -DENABLE_JABBER=OFF
# also, you can see the configure options with ccmake, then just -DOPTIONHERE=ON/OFF
diff --git a/weechat-git/weechatgit.install b/weechat-git/weechatgit.install
index f68d294..be10994 100644
--- a/weechat-git/weechatgit.install
+++ b/weechat-git/weechatgit.install
@@ -1,11 +1,6 @@
post_install() {
- echo "------------------------------------------------------------------------------"
- echo "Warning!"
- echo "It's recommended to use another WeeChat home for testing this version."
- echo "For example:"
- echo "/usr/local/bin/weechat-curses --dir /tmp/weechat"
- echo ""
- echo "You've just built weechat from GIT."
- echo "This is a development version and may therefore be unstable."
- echo "------------------------------------------------------------------------------"
+ echo "------------------------------------------------------------------------------"
+ echo "You've just built weechat from GIT."
+ echo "This is a development version and may therefore be unstable."
+ echo "------------------------------------------------------------------------------"
}