summaryrefslogtreecommitdiffstats
path: root/yaourt
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2010-05-24 22:02:28 +0200
committerFlorian Pritz <bluewind@xssn.at>2010-05-24 22:03:10 +0200
commit76b5704f46d3e59e41ed5883d23dd0d4aa818f4c (patch)
treea5adf840adb3093276c1fcf6b27135cecd935462 /yaourt
parentb37bf77aa7e3354edc3831f7c9038d77da00fec2 (diff)
downloadaur-packages-76b5704f46d3e59e41ed5883d23dd0d4aa818f4c.tar.gz
aur-packages-76b5704f46d3e59e41ed5883d23dd0d4aa818f4c.tar.xz
updates
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'yaourt')
-rw-r--r--yaourt/PKGBUILD25
-rw-r--r--yaourt/yaourt.install14
2 files changed, 39 insertions, 0 deletions
diff --git a/yaourt/PKGBUILD b/yaourt/PKGBUILD
new file mode 100644
index 0000000..6ba116d
--- /dev/null
+++ b/yaourt/PKGBUILD
@@ -0,0 +1,25 @@
+# Author: Julien MISCHKOWITZ <wain@archlinux.fr>
+# Author: tuxce <tuxce.net@gmail.com>
+pkgname=yaourt
+pkgver=0.9.3.2
+pkgrel=1
+pkgdesc="A Pacman frontend with more features and AUR support"
+arch=(any)
+url="http://www.archlinux.fr/yaourt-en/"
+license="GPL"
+depends=('wget' 'diffutils' 'pacman>=3.3.3' 'package-query')
+makedepends=('gettext')
+optdepends=('aurvote: vote for favorite packages from AUR for inclusion in [community]'
+ 'customizepkg: automatically modify PKGUILD during install/upgrade'
+ 'pacman-color: fully colorized output'
+ 'rsync: retrieve PKGBUILD from official repositories'
+ 'colordiff: colorized output with yaourt -C')
+install=yaourt.install
+backup=('etc/yaourtrc')
+source=(http://archiwain.free.fr/os/i686/$pkgname/$pkgname-$pkgver.src.tar.gz)
+md5sums=('349be19ecea6d1befd813014935e8772')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ make install DESTDIR=$pkgdir || return 1
+}
diff --git a/yaourt/yaourt.install b/yaourt/yaourt.install
new file mode 100644
index 0000000..9bd680a
--- /dev/null
+++ b/yaourt/yaourt.install
@@ -0,0 +1,14 @@
+post_install() {
+ cat <<-EndOfMessage
+ ==> to use yaourt as user,add these entries to /etc/sudoers:
+ user ALL=NOPASSWD: /usr/bin/pacman
+ user ALL=NOPASSWD: /usr/bin/pacdiffviewer
+ (Please, use sudo very carefully)
+ ==> for a full colorized output, install pacman-color and set PacmanBin in /etc/yaourtrc
+ EndOfMessage
+ /bin/true
+}
+
+post_upgrade() {
+ post_install
+}