summaryrefslogtreecommitdiffstats
path: root/pacman-git/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pacman-git/PKGBUILD')
-rw-r--r--pacman-git/PKGBUILD101
1 files changed, 0 insertions, 101 deletions
diff --git a/pacman-git/PKGBUILD b/pacman-git/PKGBUILD
deleted file mode 100644
index 51d9187..0000000
--- a/pacman-git/PKGBUILD
+++ /dev/null
@@ -1,101 +0,0 @@
-# Maintainer: Dave Reisner <d@falconindy.com>
-# Contributor: Thomas Dziedzic < gostrc at gmail >
-# Contributor: godane <slaxemulator@gmail.com.com>
-# Contributor: Andres Perera <aepd87@gmail.com>
-
-pkgname=pacman-git
-pkgver=20110428
-pkgrel=1
-pkgdesc="A library-based package manager with dependency support. git version."
-arch=('i686' 'x86_64')
-url="http://www.archlinux.org/pacman/"
-license=('GPL')
-groups=('base')
-depends=('bash' 'curl>=7.19.4' 'gpgme' 'libarchive>=2.7.1' 'pacman-mirrorlist')
-makedepends=('git' 'asciidoc')
-optdepends=('fakeroot: for makepkg usage as normal user')
-backup=(etc/pacman.conf etc/makepkg.conf)
-conflicts=('pacman')
-provides=('pacman')
-options=(!libtool !strip)
-source=(pacman.conf
- pacman.conf.x86_64
- makepkg.conf)
-md5sums=('10c2b220d4d2ec37a54ab7d8982acdd2'
- 'c6559dc43140e9023041171e72bd91e8'
- 'a7be38e9fcf92414ded8c7f9574a5a9b')
-
-_gitroot="git://projects.archlinux.org/pacman.git"
-_gitname="pacman"
-
-build() {
- msg 'Connecting to GIT server...'
-
- if [[ -d $_gitname ]]; then
- ( cd $_gitname && git pull origin )
- msg 'The local files are updated.'
- else
- git clone $_gitroot
- fi
-
- msg 'GIT checkout done or server timeout'
- msg 'Starting make...'
-
- rm -rf $_gitname-build
- git clone $_gitname{,-build}
- cd $_gitname-build
-
- ./autogen.sh
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --enable-doc \
- --enable-git-version --enable-debug
- make
-}
-
-check() {
- cd "$srcdir/$_gitname-build"
-
- make check
-}
-
-package() {
- cd "$srcdir/$_gitname-build"
-
- make DESTDIR=$pkgdir install
-
- # install Arch specific stuff
- mkdir -p $pkgdir/etc
- case "$CARCH" in
- i686)
- install -m644 $srcdir/pacman.conf $pkgdir/etc/pacman.conf
- ;;
- x86_64)
- install -m644 $srcdir/pacman.conf.x86_64 $pkgdir/etc/pacman.conf
- ;;
- esac
- install -m644 $srcdir/makepkg.conf $pkgdir/etc/
- # set things correctly in the default conf file
- case "$CARCH" in
- i686)
- mycarch="i686"
- mychost="i686-pc-linux-gnu"
- myflags="-march=i686 "
- ;;
- x86_64)
- mycarch="x86_64"
- mychost="x86_64-unknown-linux-gnu"
- myflags="-march=x86-64 "
- ;;
- esac
- sed -i $pkgdir/etc/makepkg.conf \
- -e "s|@CARCH[@]|$mycarch|g" \
- -e "s|@CHOST[@]|$mychost|g" \
- -e "s|@CARCHFLAGS[@]|$myflags|g"
-
- # install completion files
- mkdir -p $pkgdir/etc/bash_completion.d/
- install -m644 contrib/bash_completion $pkgdir/etc/bash_completion.d/pacman
- mkdir -p $pkgdir/usr/share/zsh/site-functions/
- install -m644 contrib/zsh_completion $pkgdir/usr/share/zsh/site-functions/_pacman
-}
-
-# vim: set ts=2 sw=2 et: