summaryrefslogtreecommitdiffstats
path: root/pacman-git
diff options
context:
space:
mode:
Diffstat (limited to 'pacman-git')
-rw-r--r--pacman-git/PKGBUILD101
-rw-r--r--pacman-git/makepkg.conf115
-rw-r--r--pacman-git/pacman.conf86
-rw-r--r--pacman-git/pacman.conf.x86_6491
4 files changed, 0 insertions, 393 deletions
diff --git a/pacman-git/PKGBUILD b/pacman-git/PKGBUILD
deleted file mode 100644
index 51d9187..0000000
--- a/pacman-git/PKGBUILD
+++ /dev/null
@@ -1,101 +0,0 @@
-# Maintainer: Dave Reisner <d@falconindy.com>
-# Contributor: Thomas Dziedzic < gostrc at gmail >
-# Contributor: godane <slaxemulator@gmail.com.com>
-# Contributor: Andres Perera <aepd87@gmail.com>
-
-pkgname=pacman-git
-pkgver=20110428
-pkgrel=1
-pkgdesc="A library-based package manager with dependency support. git version."
-arch=('i686' 'x86_64')
-url="http://www.archlinux.org/pacman/"
-license=('GPL')
-groups=('base')
-depends=('bash' 'curl>=7.19.4' 'gpgme' 'libarchive>=2.7.1' 'pacman-mirrorlist')
-makedepends=('git' 'asciidoc')
-optdepends=('fakeroot: for makepkg usage as normal user')
-backup=(etc/pacman.conf etc/makepkg.conf)
-conflicts=('pacman')
-provides=('pacman')
-options=(!libtool !strip)
-source=(pacman.conf
- pacman.conf.x86_64
- makepkg.conf)
-md5sums=('10c2b220d4d2ec37a54ab7d8982acdd2'
- 'c6559dc43140e9023041171e72bd91e8'
- 'a7be38e9fcf92414ded8c7f9574a5a9b')
-
-_gitroot="git://projects.archlinux.org/pacman.git"
-_gitname="pacman"
-
-build() {
- msg 'Connecting to GIT server...'
-
- if [[ -d $_gitname ]]; then
- ( cd $_gitname && git pull origin )
- msg 'The local files are updated.'
- else
- git clone $_gitroot
- fi
-
- msg 'GIT checkout done or server timeout'
- msg 'Starting make...'
-
- rm -rf $_gitname-build
- git clone $_gitname{,-build}
- cd $_gitname-build
-
- ./autogen.sh
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --enable-doc \
- --enable-git-version --enable-debug
- make
-}
-
-check() {
- cd "$srcdir/$_gitname-build"
-
- make check
-}
-
-package() {
- cd "$srcdir/$_gitname-build"
-
- make DESTDIR=$pkgdir install
-
- # install Arch specific stuff
- mkdir -p $pkgdir/etc
- case "$CARCH" in
- i686)
- install -m644 $srcdir/pacman.conf $pkgdir/etc/pacman.conf
- ;;
- x86_64)
- install -m644 $srcdir/pacman.conf.x86_64 $pkgdir/etc/pacman.conf
- ;;
- esac
- install -m644 $srcdir/makepkg.conf $pkgdir/etc/
- # set things correctly in the default conf file
- case "$CARCH" in
- i686)
- mycarch="i686"
- mychost="i686-pc-linux-gnu"
- myflags="-march=i686 "
- ;;
- x86_64)
- mycarch="x86_64"
- mychost="x86_64-unknown-linux-gnu"
- myflags="-march=x86-64 "
- ;;
- esac
- sed -i $pkgdir/etc/makepkg.conf \
- -e "s|@CARCH[@]|$mycarch|g" \
- -e "s|@CHOST[@]|$mychost|g" \
- -e "s|@CARCHFLAGS[@]|$myflags|g"
-
- # install completion files
- mkdir -p $pkgdir/etc/bash_completion.d/
- install -m644 contrib/bash_completion $pkgdir/etc/bash_completion.d/pacman
- mkdir -p $pkgdir/usr/share/zsh/site-functions/
- install -m644 contrib/zsh_completion $pkgdir/usr/share/zsh/site-functions/_pacman
-}
-
-# vim: set ts=2 sw=2 et:
diff --git a/pacman-git/makepkg.conf b/pacman-git/makepkg.conf
deleted file mode 100644
index c23d039..0000000
--- a/pacman-git/makepkg.conf
+++ /dev/null
@@ -1,115 +0,0 @@
-#
-# /etc/makepkg.conf
-#
-
-#########################################################################
-# SOURCE ACQUISITION
-#########################################################################
-#
-#-- The download utilities that makepkg should use to acquire sources
-# Format: 'protocol::agent'
-DLAGENTS=('ftp::/usr/bin/curl -fC - --ftp-pasv --retry 3 --retry-delay 3 -o %o %u'
- 'http::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -o %o %u'
- 'https::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -o %o %u'
- 'rsync::/usr/bin/rsync -z %u %o'
- 'scp::/usr/bin/scp -C %u %o')
-
-# Other common tools:
-# /usr/bin/snarf
-# /usr/bin/lftpget -c
-# /usr/bin/curl
-
-#########################################################################
-# ARCHITECTURE, COMPILE FLAGS
-#########################################################################
-#
-CARCH="@CARCH@"
-CHOST="@CHOST@"
-
-#-- Exclusive: will only run on @CARCH@
-# -march (or -mcpu) builds exclusively for an architecture
-# -mtune optimizes for an architecture, but builds for whole processor family
-CFLAGS="@CARCHFLAGS@-mtune=generic -O2 -pipe"
-CXXFLAGS="@CARCHFLAGS@-mtune=generic -O2 -pipe"
-LDFLAGS="-Wl,--hash-style=gnu -Wl,--as-needed"
-#-- Make Flags: change this for DistCC/SMP systems
-#MAKEFLAGS="-j2"
-
-#########################################################################
-# BUILD ENVIRONMENT
-#########################################################################
-#
-# Defaults: BUILDENV=(fakeroot !distcc color !ccache)
-# A negated environment option will do the opposite of the comments below.
-#
-#-- fakeroot: Allow building packages as a non-root user
-#-- distcc: Use the Distributed C/C++/ObjC compiler
-#-- color: Colorize output messages
-#-- ccache: Use ccache to cache compilation
-#
-BUILDENV=(fakeroot !distcc color !ccache)
-#
-#-- If using DistCC, your MAKEFLAGS will also need modification. In addition,
-#-- specify a space-delimited list of hosts running in the DistCC cluster.
-#DISTCC_HOSTS=""
-
-#########################################################################
-# GLOBAL PACKAGE OPTIONS
-# These are default values for the options=() settings
-#########################################################################
-#
-# Default: OPTIONS=(strip docs libtool emptydirs zipman purge)
-# A negated option will do the opposite of the comments below.
-#
-#-- strip: Strip symbols from binaries/libraries in STRIP_DIRS
-#-- docs: Save doc directories specified by DOC_DIRS
-#-- libtool: Leave libtool (.la) files in packages
-#-- emptydirs: Leave empty directories in packages
-#-- zipman: Compress manual (man and info) pages in MAN_DIRS with gzip
-#-- purge: Remove files specified by PURGE_TARGETS
-#
-OPTIONS=(strip docs libtool emptydirs zipman purge)
-
-#-- File integrity checks to use. Valid: md5, sha1, sha256, sha384, sha512
-INTEGRITY_CHECK=(md5)
-#-- Options to be used when stripping binaries. See `man strip' for details.
-STRIP_BINARIES="--strip-all"
-#-- Options to be used when stripping shared libraries. See `man strip' for details.
-STRIP_SHARED="--strip-unneeded"
-#-- Options to be used when stripping static libraries. See `man strip' for details.
-STRIP_STATIC="--strip-debug"
-#-- Manual (man and info) directories to compress (if zipman is specified)
-MAN_DIRS=({usr{,/local}{,/share},opt/*}/{man,info})
-#-- Doc directories to remove (if !docs is specified)
-DOC_DIRS=(usr/{,local/}{,share/}{doc,gtk-doc} opt/*/{doc,gtk-doc})
-#-- Directories to be searched for the strip option (if strip is specified)
-STRIP_DIRS=(bin lib sbin usr/{bin,lib,sbin,local/{bin,lib,sbin}} opt/*/{bin,lib,sbin})
-#-- Files to be removed from all packages (if purge is specified)
-PURGE_TARGETS=(usr/{,share}/info/dir .packlist *.pod)
-
-#########################################################################
-# PACKAGE OUTPUT
-#########################################################################
-#
-# Default: put built package and cached source in build directory
-#
-#-- Destination: specify a fixed directory where all packages will be placed
-#PKGDEST=/home/packages
-#-- Source cache: specify a fixed directory where source files will be cached
-#SRCDEST=/home/sources
-#-- Source packages: specify a fixed directory where all src packages will be placed
-#SRCPKGDEST=/home/srcpackages
-#-- Packager: name/email of the person or organization building packages
-#PACKAGER="John Doe <john@doe.com>"
-
-#########################################################################
-# EXTENSION DEFAULTS
-#########################################################################
-#
-# WARNING: Do NOT modify these variables unless you know what you are
-# doing.
-#
-PKGEXT='.pkg.tar.xz'
-SRCEXT='.src.tar.gz'
-
-# vim: set ft=sh ts=2 sw=2 et:
diff --git a/pacman-git/pacman.conf b/pacman-git/pacman.conf
deleted file mode 100644
index f5fcce1..0000000
--- a/pacman-git/pacman.conf
+++ /dev/null
@@ -1,86 +0,0 @@
-#
-# /etc/pacman.conf
-#
-# See the pacman.conf(5) manpage for option and repository directives
-
-#
-# GENERAL OPTIONS
-#
-[options]
-# The following paths are commented out with their default values listed.
-# If you wish to use different paths, uncomment and update the paths.
-#RootDir = /
-#DBPath = /var/lib/pacman/
-#CacheDir = /var/cache/pacman/pkg/
-#LogFile = /var/log/pacman.log
-HoldPkg = pacman glibc
-# If upgrades are available for these packages they will be asked for first
-SyncFirst = pacman
-#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
-#XferCommand = /usr/bin/curl -C - %u > %o
-#CleanMethod = KeepInstalled
-Architecture = auto
-
-# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
-#IgnorePkg =
-#IgnoreGroup =
-
-#NoUpgrade =
-#NoExtract =
-
-# Misc options (all disabled by default)
-#UseSyslog
-#ShowSize
-#UseDelta
-#TotalDownload
-
-#
-# REPOSITORIES
-# - can be defined here or included from another file
-# - pacman will search repositories in the order defined here
-# - local/custom mirrors can be added here or in separate files
-# - repositories listed first will take precedence when packages
-# have identical names, regardless of version number
-# - URLs will have $repo replaced by the name of the current repo
-# - URLs will have $arch replaced by the name of the architecture
-#
-# Repository entries are of the format:
-# [repo-name]
-# Server = ServerName
-# Include = IncludePath
-# VerifySig = Always/Optional/Never
-#
-# The header [repo-name] is crucial - it must be present and
-# uncommented to enable the repo.
-#
-
-# The testing repositories are disabled by default. To enable, uncomment the
-# repo name header and Include lines. You can add preferred servers immediately
-# after the header, and they will be used before the default mirrors.
-
-#[testing]
-#Include = /etc/pacman.d/mirrorlist
-#VerifySig = Optional
-
-[core]
-Include = /etc/pacman.d/mirrorlist
-VerifySig = Optional
-
-[extra]
-Include = /etc/pacman.d/mirrorlist
-VerifySig = Optional
-
-#[community-testing]
-#Include = /etc/pacman.d/mirrorlist
-#VerifySig = Optional
-
-[community]
-Include = /etc/pacman.d/mirrorlist
-VerifySig = Optional
-
-# An example of a custom package repository. See the pacman manpage for
-# tips on creating your own repositories.
-#[custom]
-#Server = file:///home/custompkgs
-#VerifySig = Optional
-
diff --git a/pacman-git/pacman.conf.x86_64 b/pacman-git/pacman.conf.x86_64
deleted file mode 100644
index 52b84d4..0000000
--- a/pacman-git/pacman.conf.x86_64
+++ /dev/null
@@ -1,91 +0,0 @@
-#
-# /etc/pacman.conf
-#
-# See the pacman.conf(5) manpage for option and repository directives
-
-#
-# GENERAL OPTIONS
-#
-[options]
-# The following paths are commented out with their default values listed.
-# If you wish to use different paths, uncomment and update the paths.
-#RootDir = /
-#DBPath = /var/lib/pacman/
-#CacheDir = /var/cache/pacman/pkg/
-#LogFile = /var/log/pacman.log
-HoldPkg = pacman glibc
-# If upgrades are available for these packages they will be asked for first
-SyncFirst = pacman
-#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
-#XferCommand = /usr/bin/curl -C - %u > %o
-#CleanMethod = KeepInstalled
-Architecture = auto
-
-# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
-#IgnorePkg =
-#IgnoreGroup =
-
-#NoUpgrade =
-#NoExtract =
-
-# Misc options (all disabled by default)
-#UseSyslog
-#ShowSize
-#UseDelta
-#TotalDownload
-
-#
-# REPOSITORIES
-# - can be defined here or included from another file
-# - pacman will search repositories in the order defined here
-# - local/custom mirrors can be added here or in separate files
-# - repositories listed first will take precedence when packages
-# have identical names, regardless of version number
-# - URLs will have $repo replaced by the name of the current repo
-# - URLs will have $arch replaced by the name of the architecture
-#
-# Repository entries are of the format:
-# [repo-name]
-# Server = ServerName
-# Include = IncludePath
-# VerifySig = Always/Optional/Never
-#
-# The header [repo-name] is crucial - it must be present and
-# uncommented to enable the repo.
-#
-
-# The testing repositories are disabled by default. To enable, uncomment the
-# repo name header and Include lines. You can add preferred servers immediately
-# after the header, and they will be used before the default mirrors.
-
-#[testing]
-#Include = /etc/pacman.d/mirrorlist
-#VerifySig = Optional
-
-[core]
-Include = /etc/pacman.d/mirrorlist
-VerifySig = Optional
-
-[extra]
-Include = /etc/pacman.d/mirrorlist
-VerifySig = Optional
-
-#[community-testing]
-#Include = /etc/pacman.d/mirrorlist
-#VerifySig = Optional
-
-[community]
-Include = /etc/pacman.d/mirrorlist
-VerifySig = Optional
-
-# If you want to run 32 bit applications on your x86_64 system,
-# enable the multilib repository here.
-#[multilib]
-#Include = /etc/pacman.d/mirrorlist
-#VerifySig = Optional
-
-# An example of a custom package repository. See the pacman manpage for
-# tips on creating your own repositories.
-#[custom]
-#Server = file:///home/custompkgs
-