summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrédéric Mangano-Tarumi <fmang@mg0.fr>2020-02-29 01:02:04 +0100
committerLukas Fleischer <lfleischer@archlinux.org>2020-02-29 14:56:47 +0100
commitbf7c49158c360690f79b31b5a65f0bb42e3fccb4 (patch)
tree126efc7b1e3daa98f4c5d7650e885c294c47a3ff
parent90c0a361b5cb8f72a9c908104b399451712fb7c5 (diff)
downloadaur-bf7c49158c360690f79b31b5a65f0bb42e3fccb4.tar.gz
aur-bf7c49158c360690f79b31b5a65f0bb42e3fccb4.tar.xz
test/Makefile: Run tests with prove when available
Signed-off-by: Lukas Fleischer <lfleischer@archlinux.org>
-rw-r--r--test/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/Makefile b/test/Makefile
index d310c8f5..758befa3 100644
--- a/test/Makefile
+++ b/test/Makefile
@@ -1,6 +1,13 @@
T = $(sort $(wildcard *.t))
+PROVE := $(shell command -v prove 2> /dev/null)
+
+ifdef PROVE
+check:
+ prove .
+else
check: $(T)
+endif
clean:
$(RM) -r test-results/