summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--test/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/Makefile b/test/Makefile
index d310c8f5..758befa3 100644
--- a/test/Makefile
+++ b/test/Makefile
@@ -1,6 +1,13 @@
T = $(sort $(wildcard *.t))
+PROVE := $(shell command -v prove 2> /dev/null)
+
+ifdef PROVE
+check:
+ prove .
+else
check: $(T)
+endif
clean:
$(RM) -r test-results/