summaryrefslogtreecommitdiffstats
path: root/web/html
diff options
context:
space:
mode:
authoreliott <eliott@cactuswax.net>2007-11-17 09:01:58 +0100
committerDan McGee <dan@archlinux.org>2008-01-20 07:21:18 +0100
commita9837329d697a9e18401309a1496cc3b5015bc6a (patch)
tree30bd36b85241d923958b242839de0f8202856042 /web/html
parent6dbe12264ac0998ac4b69a507c0b7c1b55c03c1f (diff)
downloadaur-a9837329d697a9e18401309a1496cc3b5015bc6a.tar.gz
aur-a9837329d697a9e18401309a1496cc3b5015bc6a.tar.xz
Hand diff of simo's patch to remove flag safe functionality.
Simo's original commit text: The idea of safe flagging is unclear, poorly named, misunderstood, and not even used. At the time this patch was created, less than a third of the packages in unsupported were flagged safe, and less than a tenth of users knew how to interpret it. The safe flag has been replaced by a disclaimer on the main page.
Diffstat (limited to 'web/html')
-rw-r--r--web/html/index.php37
-rw-r--r--web/html/packages.php49
-rw-r--r--web/html/pkgsubmit.php8
3 files changed, 1 insertions, 93 deletions
diff --git a/web/html/index.php b/web/html/index.php
index b379d4d1..854c32c0 100644
--- a/web/html/index.php
+++ b/web/html/index.php
@@ -210,11 +210,6 @@ $result = db_query($q, $dbh);
$row = mysql_fetch_row($result);
$update_count = $row[0];
-$q = "SELECT count(*) FROM Packages,PackageLocations WHERE Packages.LocationID = PackageLocations.ID AND PackageLocations.Location = 'unsupported' AND Packages.Safe = 1";
-$result = db_query($q, $dbh);
-$row = mysql_fetch_row($result);
-$safe_count = $row[0];
-
# Added the user statistcs.
# Added by: dsa <dsandrade@gmail.com>
$user = username_from_sid($_COOKIE["AURSID"]);
@@ -270,30 +265,6 @@ if (!empty($user)) {
print "</td>";
print "<td class='boxSoft'><span class='f4'>$flagged_outdated</span></td>";
print "</tr>";
-
- # Number of safe packages
- print "<tr>";
- print "<td class='boxSoft'>";
- if ($atype == 'Trusted User' || $atype == 'Developer') {
- $q = "SELECT count(*) FROM Packages,Users WHERE Packages.Safe = 1 AND Packages.VerifiedBy = Users.ID AND Users.Username='".mysql_real_escape_string($user)."'";
- $result = db_query($q, $dbh);
- $row = mysql_fetch_row($result);
- $flagged_safe = $row[0];
-
- print "<span class='f4'>".__("Flagged as safe by me")."</span>";
- }
- else
- {
- $q = "SELECT count(*) FROM Packages,Users WHERE Packages.Safe = 1 AND Packages.MaintainerUID = Users.ID AND Users.Username='".mysql_real_escape_string($user)."'";
- $result = db_query($q, $dbh);
- $row = mysql_fetch_row($result);
- $flagged_safe = $row[0];
-
- print "<span class='f4'>".__("Flagged as safe")."</span>";
- }
- print "</td>";
- print "<td class='boxSoft'><span class='f4'>$flagged_safe</span></td>";
- print "</tr>";
print "</table><br />";
}
@@ -315,13 +286,6 @@ print "</tr>";
print "<tr>";
print "<td class='boxSoft'>";
-print "<span class='f4'>".__("Packages in unsupported and flagged as safe")."</span>";
-print "</td>";
-print "<td class='boxSoft'><span class='f4'>$safe_count</span></td>";
-print "</tr>";
-
-print "<tr>";
-print "<td class='boxSoft'>";
print "<span class='f4'>".__("Packages in [community]")."</span>";
print "</td>";
print "<td class='boxSoft'><span class='f4'>$community_count</span></td>";
@@ -356,6 +320,7 @@ print "</tr>\n";
print "</table>\n";
echo "</div>\n";
# End Table 1
+echo "<span class='f4'>".__("DISCLAIMER: Unsupported PKGBUILDs are user produced content, by downloading them you agree to do so at your own risk.")."</span>";
echo " </div>";
echo "</div>";
html_footer(AUR_VERSION);
diff --git a/web/html/packages.php b/web/html/packages.php
index 2ae3bf00..95b59798 100644
--- a/web/html/packages.php
+++ b/web/html/packages.php
@@ -491,55 +491,6 @@ if (isset($_REQUEST["do_Flag"])) {
# FIXME: If someone hits the detail page's vote button, this link dies
pkgsearch_results_link();
-
-} elseif (isset($_REQUEST["do_FlagSafe"])) {
- if (!$atype) {
- print __("You must be logged in before you can flag packages.");
- print "<br />\n";
- } else {
- if (!empty($ids) && $atype == "Trusted User") {
- $dbh = db_connect();
- # There currently shouldn't be multiple requests here, but the format in which
- # it's sent requires this
- while (list($pid, $v) = each($ids)) {
- $q = "UPDATE Packages SET Safe = 1, VerifiedBy = ".uid_from_sid($_COOKIE["AURSID"])." WHERE ID = ".$pid;
- db_query($q, $dbh);
- print '<p>';
- print __("The selected packages have been flagged safe.");
- print '<br /></p>';
- pkgdetails_link($pid);
- }
- } else {
- print '<p>';
- print __("Couldn't flag package safe.");
- print '<br /></p>';
- }
- }
-
-} elseif (isset($_REQUEST["do_UnFlagSafe"])) {
- if (!$atype) {
- print __("You must be logged in before you can unflag packages.");
- print "<br />\n";
- } else {
- if (!empty($ids) && $atype == "Trusted User") {
- $dbh = db_connect();
- # There currently shouldn't be multiple requests here, but the format in which
- # it's sent requires this
- while (list($pid, $v) = each($ids)) {
- $q = "UPDATE Packages SET Safe = 0 WHERE ID = ".$pid;
- db_query($q, $dbh);
- print '<p>';
- print __("The selected packages have been unflagged safe.");
- print '<br /></p>';
- pkgdetails_link($pid);
- }
- } else {
- print '<p>';
- print __("Couldn't unflag package safe.");
- print '<br /></p>';
- }
- }
-
} elseif (isset($_REQUEST["do_Notify"])) {
# I realize that the implementation here seems a bit convoluted, but we want to
# ensure that everything happens as it should, even if someone called this page
diff --git a/web/html/pkgsubmit.php b/web/html/pkgsubmit.php
index 6e754bf6..9bed3f59 100644
--- a/web/html/pkgsubmit.php
+++ b/web/html/pkgsubmit.php
@@ -412,11 +412,6 @@ if ($_COOKIE["AURSID"]) {
$q.="Description='".mysql_real_escape_string($new_pkgbuild['pkgdesc'])."', ";
$q.="URL='".mysql_real_escape_string($new_pkgbuild['url'])."', ";
$q.="LocationID=2, ";
- if (account_from_sid($_COOKIE["AURSID"]) == "Trusted User" || account_from_sid($_COOKIE["AURSID"]) == "Developer") {
- $q.="Safe=1, VerifiedBy=".uid_from_sid($_COOKIE["AURSID"]).", ";
- } else {
- $q.="Safe=0, ";
- }
$fspath=INCOMING_DIR.$pkg_name."/".$_FILES["pfile"]["name"];
$q.="FSPath='".mysql_real_escape_string($fspath)."', ";
$urlpath=URL_DIR.$pkg_name."/".$_FILES["pfile"]["name"];
@@ -481,9 +476,6 @@ if ($_COOKIE["AURSID"]) {
#
$q = "INSERT INTO Packages ";
$q.= " (Name, License, Version, CategoryID, Description, URL, LocationID, ";
- if (account_from_sid($_COOKIE["AURSID"]) == "Trusted User" || account_from_sid($_COOKIE["AURSID"]) == "Developer") {
- $q.= "Safe, VerifiedBy,";
- }
$q.= " SubmittedTS, SubmitterUID, MaintainerUID, FSPath, URLPath) ";
$q.= "VALUES ('";
$q.= mysql_real_escape_string($new_pkgbuild['pkgname'])."', '";