summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrew Gregory <andrew.gregory.8@gmail.com>2013-07-29 21:34:04 +0200
committerAllan McRae <allan@archlinux.org>2013-08-21 03:00:18 +0200
commit228221003df40fa0782656d0e32d6ad072a4eec1 (patch)
tree620c7e5e18b95ff93cd2d60042915a6ca5387fab /Makefile.am
parent9263cc58747a1b2ed5a345e5b35014b44decd444 (diff)
downloadpacman-228221003df40fa0782656d0e32d6ad072a4eec1.tar.gz
pacman-228221003df40fa0782656d0e32d6ad072a4eec1.tar.xz
pactest: accept test names without a switch
This removes the --test switch, making it easier to call pactest from a test harness. Signed-off-by: Andrew Gregory <andrew.gregory.8@gmail.com> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 28f7f8f9..1adf0f89 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,10 +28,10 @@ check-local: test-pacman test-pacsort test-vercmp test-parseopts
test-pacman: test/pacman src/pacman
$(PYTHON) $(top_srcdir)/test/pacman/pactest.py --debug=1 \
- --test $(top_srcdir)/test/pacman/tests/*.py \
--scriptlet-shell $(SCRIPTLET_SHELL) \
--ldconfig $(LDCONFIG) \
- -p $(top_builddir)/src/pacman/pacman
+ -p $(top_builddir)/src/pacman/pacman \
+ $(top_srcdir)/test/pacman/tests/*.py
test-pacsort: test/util src/util
$(BASH_SHELL) $(top_srcdir)/test/util/pacsorttest.sh \