summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-02-22 22:34:51 +0100
committerDan McGee <dan@archlinux.org>2007-02-22 22:34:51 +0100
commit332c12710988198070fbc95cd869ca639b989238 (patch)
tree2dd7b1977f297bd660b26cef168325a347953384 /Makefile.am
parentef4728903d4c5f69100a0b3923b82b6008972c6f (diff)
downloadpacman-332c12710988198070fbc95cd869ca639b989238.tar.gz
pacman-332c12710988198070fbc95cd869ca639b989238.tar.xz
Big commit here, I'll try to cover all the bases.
* Updated all of the language files, as the POT file was updated. NOTE FOR TRANSLATORS, try to base your next contribution off of these, notice how some msgids and messages have been wrapped to the next line- it makes it easier to read anyway. * More Makefile.am/configure.ac updates. 'make dist' and 'make distclean' now work properly, with only one caveat- the automatic testing in distclean doesn't do so hot as it is compiled with a default configure, which includes the fakeroot-proof code (which does not cooperate with pactest). * Added a Makefile.am for the pactest directory.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 1074525c..68f2e240 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,9 +1,13 @@
-SUBDIRS = lib/libalpm src/util src/pacman scripts doc etc
+SUBDIRS = lib/libalpm src/util src/pacman scripts doc etc pactest
# Some files automatically included, so they aren't specified below:
# AUTHORS, COPYING, NEWS, README
# TODO: move translation-help to ABOUT-NLS?
EXTRA_DIST = HACKING
-check: src/pacman
- cd pactest; python pactest.py --test=tests/*.py -p ../src/pacman/pacman --debug=1
+# TODO : figure out a way to get 'make distcheck' to build with
+# --disable-fakeroot so it actually passes tests
+check-local: src/pacman
+ python $(top_srcdir)/pactest/pactest.py --test=$(top_srcdir)/pactest/tests/*.py -p $(top_builddir)/src/pacman/pacman --debug=1
+ rm -rf $(top_builddir)/root
+