summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 1074525c..68f2e240 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,9 +1,13 @@
-SUBDIRS = lib/libalpm src/util src/pacman scripts doc etc
+SUBDIRS = lib/libalpm src/util src/pacman scripts doc etc pactest
# Some files automatically included, so they aren't specified below:
# AUTHORS, COPYING, NEWS, README
# TODO: move translation-help to ABOUT-NLS?
EXTRA_DIST = HACKING
-check: src/pacman
- cd pactest; python pactest.py --test=tests/*.py -p ../src/pacman/pacman --debug=1
+# TODO : figure out a way to get 'make distcheck' to build with
+# --disable-fakeroot so it actually passes tests
+check-local: src/pacman
+ python $(top_srcdir)/pactest/pactest.py --test=$(top_srcdir)/pactest/tests/*.py -p $(top_builddir)/src/pacman/pacman --debug=1
+ rm -rf $(top_builddir)/root
+