summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrew Gregory <andrew.gregory.8@gmail.com>2013-07-18 09:43:51 +0200
committerAllan McRae <allan@archlinux.org>2013-08-21 03:00:18 +0200
commit403c175dbc84a8198b92bbe76f66eade613cff48 (patch)
treeb50535b3a55daf9fb5e40ccd78871d41f53414a7 /Makefile.am
parent228221003df40fa0782656d0e32d6ad072a4eec1 (diff)
downloadpacman-403c175dbc84a8198b92bbe76f66eade613cff48.tar.gz
pacman-403c175dbc84a8198b92bbe76f66eade613cff48.tar.xz
integrate tests with automake
Signed-off-by: Andrew Gregory <andrew.gregory.8@gmail.com> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am38
1 files changed, 17 insertions, 21 deletions
diff --git a/Makefile.am b/Makefile.am
index 1adf0f89..77bc06da 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,29 +23,25 @@ dist_pkgdata_DATA = \
proto/proto.install \
proto/ChangeLog.proto
-# run the pactest test suite and vercmp tests
-check-local: test-pacman test-pacsort test-vercmp test-parseopts
-
-test-pacman: test/pacman src/pacman
- $(PYTHON) $(top_srcdir)/test/pacman/pactest.py --debug=1 \
+TESTS = test/scripts/parseopts_test.sh \
+ test/scripts/human_to_size_test.sh \
+ test/util/pacsorttest.sh \
+ test/util/vercmptest.sh
+include $(top_srcdir)/test/pacman/tests/TESTS
+
+TEST_EXTENSIONS = .py
+AM_TESTS_ENVIRONMENT = \
+ PMTEST_UTIL_DIR=$(top_srcdir)/src/util/; export PMTEST_UTIL_DIR; \
+ PMTEST_SCRIPTLIB_DIR=$(top_srcdir)/scripts/library/; export PMTEST_SCRIPTLIB_DIR;
+TEST_LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+ $(top_srcdir)/build-aux/tap-driver.sh
+PY_LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+ $(top_srcdir)/build-aux/tap-driver.sh
+PY_LOG_COMPILER = test/pacman/pactest.py
+AM_PY_LOG_FLAGS = \
--scriptlet-shell $(SCRIPTLET_SHELL) \
--ldconfig $(LDCONFIG) \
- -p $(top_builddir)/src/pacman/pacman \
- $(top_srcdir)/test/pacman/tests/*.py
-
-test-pacsort: test/util src/util
- $(BASH_SHELL) $(top_srcdir)/test/util/pacsorttest.sh \
- $(top_builddir)/src/util/pacsort
-
-test-vercmp: test/util src/util
- $(BASH_SHELL) $(top_srcdir)/test/util/vercmptest.sh \
- $(top_builddir)/src/util/vercmp
-
-test-parseopts: test/scripts scripts
- $(BASH_SHELL) $(top_srcdir)/test/scripts/parseopts_test.sh \
- $(top_srcdir)/scripts/library/parseopts.sh
- $(BASH_SHELL) $(top_srcdir)/test/scripts/human_to_size_test.sh \
- $(top_srcdir)/scripts/library/human_to_size.sh
+ -p $(top_builddir)/src/pacman/pacman
# create the pacman DB and cache directories upon install
install-data-local: