summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-11-01 04:19:03 +0100
committerDan McGee <dan@archlinux.org>2007-11-04 17:42:07 +0100
commitc26fe63ee5d84492bcfb36664af8a90619e6ded5 (patch)
tree591814b7bf5a0cc483f56968797e0c64556a81e7 /configure.ac
parent8feccaed7861010caefa4f7b9824a612a78e3043 (diff)
downloadpacman-c26fe63ee5d84492bcfb36664af8a90619e6ded5.tar.gz
pacman-c26fe63ee5d84492bcfb36664af8a90619e6ded5.tar.xz
Add some more autoconf macros to filter our CFLAGS usage
Hopefully these new autoconf macros, with a little magic, will allow us to compile with any compiler and still choose the options we have available to us. Tested locally with gcc 4.2.2 and gcc 3.4.6; the latter doesn't support two of the items we previously had hardcoded in our CFLAGS. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d93cea84..823d4691 100644
--- a/configure.ac
+++ b/configure.ac
@@ -162,6 +162,11 @@ AC_CHECK_FUNCS([realpath regcomp strcasecmp strdup strerror strnlen \
# Enable large file support if available
AC_SYS_LARGEFILE
+# Check if we can use symbol visibility support in GCC
+GCC_VISIBILITY_CC
+# Check if we have -fgnu89-inline flag
+GCC_GNU89_INLINE_CC
+
# Host-dependant flags
case "${host}" in
*-*-cygwin*)