summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Reisner <d@falconindy.com>2011-03-18 02:34:01 +0100
committerDan McGee <dan@archlinux.org>2011-03-23 09:43:17 +0100
commitdb49c4a7f0145bd25ca570f23875065041d13aa4 (patch)
tree500ec70567a55b0393237461a6c64c64592d00a5 /configure.ac
parent2f060dec6ad9aa77b0d8bff1b2e83e056cd59827 (diff)
downloadpacman-db49c4a7f0145bd25ca570f23875065041d13aa4.tar.gz
pacman-db49c4a7f0145bd25ca570f23875065041d13aa4.tar.xz
buildsys: use libcurl's m4 macro for buildtime detection
Signed-off-by: Dave Reisner <d@falconindy.com> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 2 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index defa3da1..87330afc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,10 +93,8 @@ AC_ARG_WITH(openssl,
AS_HELP_STRING([--with-openssl], [use OpenSSL crypto implementations instead of internal routines]),
[], [with_openssl=check])
-# Help line for libcurl
-AC_ARG_WITH(curl,
- AS_HELP_STRING([--with-curl], [use libcurl as an internal downloader]),
- [], [with_curl=check])
+# Check for useable libcurl
+LIBCURL_CHECK_CONFIG([yes], [7.19.4])
# Help line for documentation
AC_ARG_ENABLE(doc,
@@ -149,18 +147,6 @@ AS_IF([test "x$with_openssl" != "xno"],
AC_MSG_RESULT(no))
AM_CONDITIONAL([HAVE_LIBSSL], [test "x$ac_cv_lib_ssl_MD5_Final" = "xyes"])
-# Enable or disable usage of libcurl
-AC_MSG_CHECKING(whether to link with libcurl)
-AS_IF([test "x$with_curl" != "xno"],
- [AC_MSG_RESULT(yes)
- AC_CHECK_LIB([curl], [curl_easy_perform], ,
- [if test "x$with_curl" != "xcheck"; then
- AC_MSG_FAILURE([--with-curl was given, but -lcurl was not found])
- fi],
- [-lcurl])],
- AC_MSG_RESULT(no))
-AM_CONDITIONAL([HAVE_LIBCURL], [test "x$ac_cv_lib_curl_curl_easy_perform" = "xyes"])
-
# Check for gpgme
AC_CHECK_LIB([gpgme], [gpgme_check_version], ,
AC_MSG_ERROR([gpgme is needed to compile pacman!]))