summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 2 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index defa3da1..87330afc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,10 +93,8 @@ AC_ARG_WITH(openssl,
AS_HELP_STRING([--with-openssl], [use OpenSSL crypto implementations instead of internal routines]),
[], [with_openssl=check])
-# Help line for libcurl
-AC_ARG_WITH(curl,
- AS_HELP_STRING([--with-curl], [use libcurl as an internal downloader]),
- [], [with_curl=check])
+# Check for useable libcurl
+LIBCURL_CHECK_CONFIG([yes], [7.19.4])
# Help line for documentation
AC_ARG_ENABLE(doc,
@@ -149,18 +147,6 @@ AS_IF([test "x$with_openssl" != "xno"],
AC_MSG_RESULT(no))
AM_CONDITIONAL([HAVE_LIBSSL], [test "x$ac_cv_lib_ssl_MD5_Final" = "xyes"])
-# Enable or disable usage of libcurl
-AC_MSG_CHECKING(whether to link with libcurl)
-AS_IF([test "x$with_curl" != "xno"],
- [AC_MSG_RESULT(yes)
- AC_CHECK_LIB([curl], [curl_easy_perform], ,
- [if test "x$with_curl" != "xcheck"; then
- AC_MSG_FAILURE([--with-curl was given, but -lcurl was not found])
- fi],
- [-lcurl])],
- AC_MSG_RESULT(no))
-AM_CONDITIONAL([HAVE_LIBCURL], [test "x$ac_cv_lib_curl_curl_easy_perform" = "xyes"])
-
# Check for gpgme
AC_CHECK_LIB([gpgme], [gpgme_check_version], ,
AC_MSG_ERROR([gpgme is needed to compile pacman!]))