summaryrefslogtreecommitdiffstats
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-04-26 22:59:38 +0200
committerDan McGee <dan@archlinux.org>2007-04-26 22:59:38 +0200
commit7bbcaaaae90770247f72cf213498b6934d949023 (patch)
treefb6619b04ab85b3584f6753c34e01ceb4f892088 /src/util/Makefile.am
parent8d46cf6651e4593786621be62216c6ef9f03a172 (diff)
downloadpacman-7bbcaaaae90770247f72cf213498b6934d949023.tar.gz
pacman-7bbcaaaae90770247f72cf213498b6934d949023.tar.xz
Add -pedantic flag to pacman (frontend) CFLAGS
Now that we got rid of the ERR and WARN macros, compilation with -pedantic turned on works with only minor changes. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index e79e726d..8174dd96 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -2,6 +2,8 @@ bin_PROGRAMS = vercmp testpkg
INCLUDES = -I$(top_srcdir)/lib/libalpm
+AM_CFLAGS = -pedantic
+
vercmp_SOURCES = vercmp.c
vercmp_LDADD = $(top_builddir)/lib/libalpm/.libs/libalpm.la