summaryrefslogtreecommitdiffstats
path: root/apcupsd-cli
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2010-07-13 09:05:18 +0200
committerFlorian Pritz <bluewind@xssn.at>2010-07-13 09:05:18 +0200
commit953368befe24437af41c0309263040ec6ce5d25d (patch)
tree5f9275898d8fa8d88ae43d0e696b5c7c20d56244 /apcupsd-cli
parent8d23351755ef023dc68e90de539ae086dda7dcec (diff)
downloadaur-packages-953368befe24437af41c0309263040ec6ce5d25d.tar.gz
aur-packages-953368befe24437af41c0309263040ec6ce5d25d.tar.xz
update
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'apcupsd-cli')
-rw-r--r--apcupsd-cli/PKGBUILD36
-rwxr-xr-xapcupsd-cli/apcupsd44
2 files changed, 80 insertions, 0 deletions
diff --git a/apcupsd-cli/PKGBUILD b/apcupsd-cli/PKGBUILD
new file mode 100644
index 0000000..ba47f08
--- /dev/null
+++ b/apcupsd-cli/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 8842 2010-01-21 22:55:25Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Todd Musall <tmusall@comcast.net>
+
+pkgname=apcupsd-cli
+_orig=apcupsd
+pkgver=3.14.8
+pkgrel=1
+pkgdesc="Apcupsd version without GUI and webinterface"
+arch=(i686 x86_64)
+url="http://www.apcupsd.org"
+license=('GPL')
+depends=('gcc-libs')
+makedepends=('pkgconfig')
+conflicts=('apcupsd')
+backup=(etc/apcupsd/apcupsd.conf etc/apcupsd/hosts.conf \
+ etc/apcupsd/multimon.conf)
+source=(http://downloads.sourceforge.net/apcupsd/$_orig-$pkgver.tar.gz \
+ apcupsd)
+md5sums=('cd17f0a903dc2220e55ed54e242359d2'
+ '5eae3c4d921eeb81798a0250fe3dd111')
+
+build() {
+ cd $startdir/src/$_orig-$pkgver
+ ./configure --prefix=/usr --libexecdir=/usr/lib/$_orig \
+ --enable-usb --enable-net \
+ --with-upstype=usb --with-upscable=usb \
+ --with-serial-dev=/dev/usb/hid/hiddev[0-9] \
+ --enable-pthreads
+
+ make || return 1
+ make DESTDIR=$startdir/pkg install || return 1
+
+ install -D -m755 ../apcupsd $startdir/pkg/etc/rc.d/apcupsd && \
+ chmod 755 $startdir/pkg/sbin/*
+}
diff --git a/apcupsd-cli/apcupsd b/apcupsd-cli/apcupsd
new file mode 100755
index 0000000..3cd5c9d
--- /dev/null
+++ b/apcupsd-cli/apcupsd
@@ -0,0 +1,44 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /sbin/apcupsd`
+case "$1" in
+ start)
+ stat_busy "Starting APCUPSD Daemon"
+ rm -f /etc/apcupsd/powerfail
+ rm -f /etc/nologin
+ [ -z "$PID" ] && /sbin/apcupsd -f /etc/apcupsd/apcupsd.conf
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ PID=`pidof -o %PPID /sbin/apcupsd`
+ echo $PID > /var/run/apcupsd.pid
+ add_daemon apcupsd
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping APCUPSD Daemon"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm /var/run/apcupsd.pid
+ rm_daemon apcupsd
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 2
+ $0 start
+ ;;
+ status)
+ /sbin/apcaccess status
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart|status}"
+esac
+exit 0