summaryrefslogtreecommitdiffstats
path: root/thunderbird3/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-11-22 21:42:30 +0100
committerFlorian Pritz <bluewind@xssn.at>2009-11-22 21:42:30 +0100
commit7155de6730bac6549b53cb08b746581d5ce4fa50 (patch)
treeba3f486c77c0608a2a108047cde2eeb612901d90 /thunderbird3/PKGBUILD
parentac2be60a6f3e6805f9c4a5986fc9bdc67798f4c5 (diff)
downloadaur-packages-7155de6730bac6549b53cb08b746581d5ce4fa50.tar.gz
aur-packages-7155de6730bac6549b53cb08b746581d5ce4fa50.tar.xz
updates
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'thunderbird3/PKGBUILD')
-rw-r--r--thunderbird3/PKGBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/thunderbird3/PKGBUILD b/thunderbird3/PKGBUILD
new file mode 100644
index 0000000..4e1a659
--- /dev/null
+++ b/thunderbird3/PKGBUILD
@@ -0,0 +1,57 @@
+# Contibutor: Andreas Schönfelder <passtschu at freenet dot de>
+
+pkgname=thunderbird3
+pkgver=3.0b4
+pkgrel=5
+pkgdesc="Standalone Mail/News reader (installs besides thunderbird2)"
+arch=('i686' 'x86_64')
+license=('MPL' 'GPL')
+url="http://www.mozilla.org/projects/thunderbird"
+depends=('gtk2>=2.14.7' 'gcc-libs>=4.3.3' 'libidl2' 'mozilla-common' 'libxt' 'shared-mime-info')
+makedepends=('zip' 'pkgconfig' 'imagemagick' 'libgnomeui' 'dbus' 'python')
+options=('!ccache' '!distcc')
+source=(ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${pkgver}/source/thunderbird-${pkgver}.source.tar.bz2
+ mozconfig
+ thunderbird3.desktop
+ default_locale.patch)
+md5sums=('0f7c7cdfebd8948b7e3fe835773b072d'
+ '8a3b273574d76f6cb3a255afce84e00c'
+ 'da268f4dbf6fbb8efa13221f39d9fb32'
+ '39fe15f99264dc1b6776059de87dfa88')
+
+build() {
+ cd "${srcdir}"
+ cp "${srcdir}/mozconfig" comm-central/.mozconfig
+ cd comm-central/
+
+ patch -Np1 -i "${srcdir}/default_locale.patch" || return 1
+
+ unset CFLAGS
+ unset CXXFLAGS
+ unset LDFLAGS
+
+ if [ "${CARCH}" = "x86_64" ]; then
+ echo "ac_cv_visibility_pragma=no" >> .mozconfig
+ fi
+
+ export MOZ_PROJECT=mail
+
+ make -f client.mk build || return 1
+ make -j1 DESTDIR="${pkgdir}" -C objdir-tb install|| return 1
+
+ rm -rf "${pkgdir}/usr/bin/defaults"
+
+ mv "${pkgdir}/usr/bin/thunderbird"{,3}
+ install -m755 -d "${pkgdir}/usr/share/applications"
+ install -m755 -d "${pkgdir}/usr/share/pixmaps"
+ install -m644 "${srcdir}/comm-central/other-licenses/branding/thunderbird/mailicon48.png" "${pkgdir}/usr/share/pixmaps/thunderbird3.png"
+
+ #Is this a bug??? What happened to default.xpm?!
+ convert "${srcdir}/comm-central/other-licenses/branding/thunderbird/mailicon48.png" "${srcdir}/comm-central/other-licenses/branding/thunderbird/default.xpm"
+
+ install -m644 "${srcdir}/comm-central/other-licenses/branding/thunderbird/default.xpm" \
+ "${pkgdir}/usr/lib/thunderbird-${pkgver}/icons/" || return 1
+ install -m644 "${srcdir}/thunderbird3.desktop" "${pkgdir}/usr/share/applications/"
+
+ rm -f ${pkgdir}/usr/lib/pkgconfig/thunderbird-ns{s,pr}.pc
+}