summaryrefslogtreecommitdiffstats
path: root/vim
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xssn.at>2009-11-01 11:55:07 +0100
committerFlorian Pritz <bluewind@xssn.at>2009-11-01 11:55:07 +0100
commit833dcdb1ed487375152a5a66dda0be87f07a066e (patch)
tree4a0ef1154a6ba9eb2392b77bac3dfe85ac51d586 /vim
parentf49a0527334a7fc7f41d7b6b97783aac30c9a302 (diff)
downloadaur-packages-833dcdb1ed487375152a5a66dda0be87f07a066e.tar.gz
aur-packages-833dcdb1ed487375152a5a66dda0be87f07a066e.tar.xz
upstream updates
Signed-off-by: Florian Pritz <bluewind@xssn.at>
Diffstat (limited to 'vim')
-rw-r--r--vim/PKGBUILD15
-rw-r--r--vim/archlinux.vim2
-rw-r--r--vim/fetch_runtime.sh2
-rw-r--r--vim/vimrc6
4 files changed, 15 insertions, 10 deletions
diff --git a/vim/PKGBUILD b/vim/PKGBUILD
index c3faac6..d879d73 100644
--- a/vim/PKGBUILD
+++ b/vim/PKGBUILD
@@ -3,16 +3,16 @@
pkgname=vim
_srcver=7.2
-_patchlevel=234
+_patchlevel=267
pkgver=${_srcver}.${_patchlevel}
pkgrel=1
pkgdesc='Vi Improved, a highly configurable, improved version of the vi text editor'
arch=(i686 x86_64)
license=('custom:vim')
url="http://www.vim.org"
-depends=('gpm' 'coreutils')
+depends=('gpm' 'coreutils' 'python')
makedepends=('wget' 'sed' 'grep' 'gettext' 'perl')
-optdepends=('perl: the runtime provides a view useful perl scripts')
+optdepends=('perl: the runtime provides a few useful perl scripts')
backup=(etc/vimrc)
install=${pkgname}.install
# we need the extra-stuff to get all patches applied smoothly
@@ -36,7 +36,7 @@ build()
--with-compiledby=ArchLinux --with-features=big \
--enable-gpm --enable-acl --with-x=no --disable-gui \
--enable-multibyte --enable-cscope \
- --enable-perlinterp
+ --enable-perlinterp --enable-pythoninterp
#--with-global-runtime=/usr/share/vim --with-vim-name=vim \
make || return 1
make VIMRCLOC=/etc DESTDIR=${pkgdir} install
@@ -67,3 +67,10 @@ build()
cd ${pkgdir}/usr/share/licenses/vim
ln -s ../../vim/${_versiondir}/doc/uganda.txt license.txt
}
+md5sums=('f0901284b338e448bfd79ccca0041254'
+ '35e04482f07c57221c9a751aaa3b8dac'
+ 'd8884786979e0e520c112faf2e176f05'
+ '6d7e8d7868e8bfaa9a5880cd9c439320'
+ '45c1c3c6aff7de0d8fc2a9d8cd5cec7d'
+ '98a6065e21cba417870a66b78e9f0210'
+ '10353a61aadc3f276692d0e17db1478e')
diff --git a/vim/archlinux.vim b/vim/archlinux.vim
index af7645f..148bb93 100644
--- a/vim/archlinux.vim
+++ b/vim/archlinux.vim
@@ -5,8 +5,6 @@
" NEVER EDIT THIS FILE, IT'S OVERWRITTEN UPON UPGRADES, GLOBAL CONFIGURATION
" SHALL BE DONE IN /etc/vimrc, USER SPECIFIC CONFIGURATION IN ~/.vimrc
-set runtimepath=~/.vim,/usr/share/vim,/usr/share/vim/vimcurrent
-
" Normally we use vim-extensions. If you want true vi-compatibility
" remove change the following statements
set nocompatible " Use Vim defaults instead of 100% vi compatibility
diff --git a/vim/fetch_runtime.sh b/vim/fetch_runtime.sh
index 61c59ae..5825447 100644
--- a/vim/fetch_runtime.sh
+++ b/vim/fetch_runtime.sh
@@ -110,7 +110,7 @@ update_runtime() {
sed -i "/find the end/,+3{s/changelog_date_entry_search/changelog_date_end_entry_search/}" ftplugin/changelog.vim
fi
# make Aaron happy
- wget http://www.vim.org/scripts/download_script.php\?src_id=7766 \
+ wget http://www.vim.org/scripts/download_script.php\?src_id=10872 \
-O autoload/pythoncomplete.vim
cd "${_OLDDIR}"
return 0
diff --git a/vim/vimrc b/vim/vimrc
index 55fbc38..627d028 100644
--- a/vim/vimrc
+++ b/vim/vimrc
@@ -1,5 +1,5 @@
" All system-wide defaults are set in $VIMRUNTIME/archlinux.vim (usually just
-" /usr/share/vim/vimcurrent/archlinux.vim) and sourced by the call to :runtime
+" /usr/share/vim/vimfiles/archlinux.vim) and sourced by the call to :runtime
" you can find below. If you wish to change any of those settings, you should
" do it in this file (/etc/vimrc), since archlinux.vim will be overwritten
" everytime an upgrade of the vim packages is performed. It is recommended to
@@ -11,6 +11,6 @@
runtime! archlinux.vim
-" For more option refer to /usr/share/vim/vimcurrent/vimrc_example.vim or the
-" vim manual
+" For more option refer to /usr/share/vim/vim72/vimrc_example.vim or the vim
+" manual